nyoj_t218(Dinner)

描述
Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.
输入
There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.
输出
For each test of the input, output all the name of tableware.
样例输入
3 basketball fork chopsticks
2 bowl letter
样例输出
fork chopsticks
bowl

提示

The tableware only contains: bowl, knife, fork and chopsticks.

#include <cstring>
#include <string>
using namespace std;
int main()
{
	int n,i;
	char a[1010][20];
	//char *s1 = "bowl";
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		for (i=0;i<n;i++)
			scanf("%s",a[i]);
		for (i=0;i<n;i++)
		{
			if(strcmp(a[i],"bowl") == 0)
				printf("bowl ");
			if(strcmp(a[i],"knife") == 0)
				printf("knife ");
			if(strcmp(a[i],"fork") == 0)
				printf("fork ");
			if(strcmp(a[i],"chopsticks") == 0)
				printf("chopsticks ");
		}
		printf("\n");
	}
	return 0;
}
同样的正常运行,下面的代码就是提交不正确,

给出这样的提示错误,不能明白这是什么道理,在这里,看似没有使用指针,实际上是在无数的指针在使用着,指针的使用需要严格按照格式,不得出现任何的错误。

运行时出错:
常见出错的原因可能有以下几种:
1、数组开得太小了,导致访问到了不该访问的内存区域
2、发生除零错误
3、大数组定义在函数内,导致程序栈区耗尽
4、指针用错了,导致访问到不该访问的内存区域
5、还有可能是程序抛出了未接收的异常


 
#include <stdio.h>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;
int main()
{
	int n,i;
	char a[1010][20];
	//char *s1 = "bowl";
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		while (n--)
		{
			scanf("%s",a[i]);
			if(strcmp(a[i],"bowl") == 0)
				printf("bowl ");
			if(strcmp(a[i],"knife") == 0)
				printf("knife ");
			if(strcmp(a[i],"fork") == 0)
				printf("fork ");
			if(strcmp(a[i],"chopsticks") == 0)
				printf("chopsticks ");
		}
		printf("\n");
	}
	return 0;
}
        




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值