UVa489 Hangman Judge


 Hangman Judge 

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. Foreach game, the answer to the puzzle is given as well as the guesses. Rules are the same as theclassic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in thesolution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, whichneeds 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

       ______   
       |  |     
       |  O     
       | /|\    
       |  |     
       | / \    
     __|_       
     |   |______
     |_________|
  4. If the drawing of the hangman is completed before the contestant has successfully guessed allthe characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, thecontestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins,loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the statusof a game. All input will be in lower case. The first line of each section will contain a number toindicate which round of the game is being played; the next line will be the solution to the puzzle;the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.

这题大意就是有种吊人游戏,给定一串字符串,要求猜出该字符串的字母组成,对于这个游戏,每猜错一次字母,便要在吊人上画上一笔,当 猜错7次,就表示吊人完成,即游戏失败,若在这7笔之内完全猜出字母组合即获胜,否则就代表该游戏者胆小放弃了。现在我们就要模拟这个过程判断游戏的结果,要注意的就是每个正确的字母只能算一次,当其被重复猜测是也被视为错误,以及每个错误的字母多次猜测也需视为多次错误。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
using namespace std;

int main() {
	int Case;
	cin >> Case;
	while (Case--) {
		int a;
		int b;
		cin >> a >> b;
		while (b--) {
			for (int i = 1; i <= a; i++) {
				for (int j = 1; j <= i; j++) {
					cout << i;
				}
				cout << endl;
			}
			for (int i = a-1; i > 0; i--) {
				for (int j = i; j > 0; j--) {
					cout << i;
				}
				cout << endl;
			}
			if (b)
				cout << endl;
		}
		if (Case)
			cout << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值