山东理工OJ【2122】数据结构实验之链表七:单链表中重复元素的删除(两种思想)

15 篇文章 0 订阅


数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n;  
第二行输入n个整数。

输出

第一行输出初始链表元素个数;  
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30

示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
 
 
方法一:先固定一个元素,看其后是否有与其data相同的数,若有,则删除;若没有,则让此固定元素的下一个数当新的固定元素,重复查找。直到固定元素为最后一个元素。
#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    int i;
    struct node *p,*head;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    for(i=0; i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return head;
};//逆序建立链表
int operate(struct node *head,int n)
{
    struct node *p,*q,*t;
    p=head->next;
    while(p->next!=NULL)
    {
        q=p;
        t=q->next;
        while(t->next!=NULL)
        {
            if(t->data==p->data)
            {
                q->next=t->next;
                free(t);
                t=q->next;
                n--;
            }
            else
            {
                q=t;
                t=t->next;
            }
        }
        if(t->next==NULL)
        {
            if(t->data==p->data)
            {
                q->next=NULL;
                free(t);
                n--;
            }
        }//若第一个数与p->data相等,则删除此节点
        p=p->next;
    }
    return n;
};
void show(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p=p->next;
    }
}
int main()
{
    int n,m;
    struct node *head;
    scanf("%d",&n);
    head=creat(n);
    printf("%d\n",n);
    show(head);
    m=operate(head,n);
    printf("%d\n",m);
    show(head);
    return 0;
}


方法二:从前往后遍历链表看前边的节点是否有与其数值相同的,若没有,则将此值添加到前边的链表中;最后输出前边部分的链表就OK

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)
{
    int i;
    struct node *head,*p;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    for(i=0;i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return head;
};
int operate(struct node *head,int n)
{
    struct node *p,*q,*t;
    int num=1,flag;
    p=head->next;
    q=head->next->next;
    while(q!=NULL)
    {
        t=head->next;
        flag=0;
        while(t!=p->next)
        {
            if(t->data==q->data)
            {
                flag=1;
                break;
            }
            t=t->next;
        }
        if(flag==0)//将当前值添加到前方的链表中
        {
            p->next->data=q->data;
            p=p->next;
            num++;
        }
        q=q->next;
    }
    p->next=NULL;
    return num;
}
void show(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL)
            printf("%d\n",p->data);
        else
            printf("%d ",p->data);
        p=p->next;
    }
}
int main()
{
    int n,m;
    struct node *head;
    scanf("%d",&n);
    head=creat(n);
    printf("%d\n",n);
    show(head);
    m=operate(head,n);
    printf("%d\n",m);
    show(head);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值