【2428】Ubiquitous Religions SDUTOJ

本文深入探讨了信息技术领域的多个细分技术领域,包括前端开发、后端开发、移动开发、游戏开发等,涵盖了从基础到进阶的技术知识,为读者提供了一个全面的视角来了解和掌握信息技术的最新动态。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >



Ubiquitous Religions

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 
 
You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

输入

 The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

输出

 For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

示例输入

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

示例输出

Case 1: 1
Case 2: 7

本题主要运用了并查集与哈希的方法,大意为输入n、m,找出这n个人中,一共有多少信仰的宗教,即有多少个不同的根节点

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int father[50010];
int f[50010];//用于哈希查找
int fin(int a)//查找根节点的函数
{
    if(a!=father[a])
        father[a]=fin(father[a]);//路径压缩
    return  father[a];
}
void un(int a,int b)//集合合并函数
{
    int x=fin(a);
    int y=fin(b);
    if(x!=y)
        father[y]=x;
}
int main()
{
    int n,m,i,j,a,b;
    int k=1;
    while(~scanf("%d %d",&n,&m)&&n!=0&&m!=0)
    {
        int num=0;//记录根节点的个数
        memset(f,0,sizeof(f));
        for(i=1; i<=n; i++)
            father[i]=i;
        for(i=0; i<m; i++)
        {
            scanf("%d %d",&a,&b);
            un(a,b);
        }
        for(i=1; i<=n; i++)
        {
            j=fin(i);
            f[j]++;//哈希算法,将存在的某一个根节点记入数组中
        }
        for(i=1; i<=n; i++)
        {
            if(f[i]>0)
                num++;
        }
        printf("Case %d: %d\n",k++,num);
    }
    return 0;

}
   

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值