【模拟枚举】Arithmetic Progressions等差数列(Usaco_Training 1.4)

该博客主要介绍了如何解决Usaco_Training中1.4题目的问题,即查找所有长度为n的等差数列,这些数列的元素属于由非负整数的平方和组成的集合S。程序需在5秒内完成,输出包括序列起始元素和连续元素间的差值。博客提供了输入输出格式示例,并指出可以采用枚举法,通过优先队列优化查找过程。
摘要由CSDN通过智能技术生成
Arithmetic Progressions

An arithmetic progression is a sequence of the form a, a+b, a+2b, ..., a+nb where n=0,1,2,3,... . For this problem, a is a non-negative integer and b is a positive integer.

Write a program that finds all arithmetic progressions of length n in the set S of bisquares. The set of bisquares is defined as the set of all integers of the form p2 + q2(where p and q are non-negative integers).

TIME LIMIT: 5 secs

PROGRAM NAME: ariprog

INPUT FORMAT

Line 1:N (3 <= N <= 25), the length of progressions for which to search
Line 2:M (1 <= M <= 250), an upper bound to limit the search to the bisquares with 0 <= p,q <= M.

SAMPLE INPUT (file ariprog.in)

5
7

OUTPUT FORMAT

If no sequence is found, a singe line reading `NONE'. Otherwise, output one or more lines, each with two integers: the first element in a found sequence and the difference between consecutive elements in the same sequence. The lines should be ordered with smallest-difference sequences first and smallest starting number within those sequences first.

There will be no more than 10,000 sequences.

SAMPLE OUTPUT (file ariprog.out)

1 4
37 4
2 8
29 8
1 12
5 12
13 12
17 12
5 20
2 24

 

依次枚举a和b即可,最后由于按照b排序,所以可以把b的循环放在外层,也可以用一个优先队列存储

C++ Code

/*
ID: jiangzh15
TASK: ariprog
LANG: C++
http://blog.csdn.net/jiangzh7
*/
#include<cstdio>
#include<utility>
#include<queue>
using namespace std;

bool h[250*250*2+10];
int n,m,maxv;

bool check(int a,int b)
{
    for(int i=0;i<n;i++)
        if(!h[a+i*b]) return false;
    return true;
}

int main()
{
    freopen("ariprog.in","r",stdin);
    freopen("ariprog.out","w",stdout);
    scanf("%d%d",&n,&m);
    int i,j;
    for(i=0;i<=m;i++)
        for(j=0;j<=m;j++)
            h[i*i+j*j]=true;
    maxv=m*m*2;
    bool flag=false;
    for(j=1;j<=maxv;j++)//由于按照b排序  所以b放在外层
        for(i=0;i<=maxv;i++)
        {
            if(i+(n-1)*j>maxv)break;
            if(check(i,j))
            {
                printf("%d %d\n",i,j);
                flag=true;
            }
        }
    if(!flag)printf("NONE\n");
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值