2017年“嘉杰信息杯” 中国大学生程序设计竞赛全国邀请赛:I— Strange Optimization

题目链接:传送门

Strange Optimization

Bobo is facing a strange optimization problem. Given  n,m , he is going to find a real number  α  such that  f(12+α)  is maximized, where  f(t)=mini,jZ|injm+t| . Help him!

Note: It can be proved that the result is always rational.

Input

The input contains zero or more test cases and is terminated by end-of-file.

Each test case contains two integers  n,m .

  • 1n,m109
  • The number of tests cases does not exceed  104 .

Output

For each case, output a fraction  p/q  which denotes the result.

Sample Input

1 1
1 2

Sample Output

1/2
1/4

Note

For the first sample,  α=0  maximizes the function.


解题思路:f(t) = 1/Icm(n,m)*2

|i/n-j/m|所能表示的最小值为1/Icm(n,m),令其为p,当t>=p,f(t)=0。当t<p,只有t=p/2时,f(t)才能取到最大值p/2。

#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <iostream>  
#include <queue>
#include <set>
#include <string>
#include <stack>
#include <algorithm>
#include <map>
using namespace std;  
typedef  __int64 ll;
const int N = 100100;
const int M = 20;
const int INF = 0x3fffffff;

int gcd( int a , int b )
{
	if( b == 0 ) return a;
	else return gcd( b , a%b );
}

int main()
{
	ll n,m;
	while( ~scanf("%I64d%I64d",&n,&m) ){
		ll p = n/gcd(n,m)*m*2;
		printf("%d/%I64d\n",1,p);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值