hdu3018—Ant Trip(欧拉回路一笔画问题)

题目链接:传送门

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2898    Accepted Submission(s): 1158


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
  
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.

解题思路:图不一定联通,对每一个子图,如果只有一个点忽视它;如果没有奇度结点,需要一个group;有奇度结点n个,group的个数=n/2;


#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <iostream>  
#include <queue>
#include <set>
#include <string>
#include <stack>
#include <algorithm>
#include <map>
using namespace std;  
typedef __int64 ll;
const int N = 100005;
const int M = 50800;
const int INF = 0x3fffffff;
const int mod = 1e9+7;
const double Pi = acos(-1.0);
const double sm = 1e-9;

int rec[N],parent[N],tick[N],ret[N];
//ret标记每个子图中有多少个点,
//tick标记每个子图中奇度结点的个数

int find( int a )
{
	int b = a;
	while( b != parent[b] ){
		parent[b] = parent[parent[b]];
		b = parent[b];
	}
	return b;
}

void merge( int a , int b )
{
	int i = find(a);
	int j = find(b);
	if( i != j ) parent[i] = j;
}

void init()
{
	fill( rec , rec+N , 0 );
	fill( ret , ret+N , 0 );
	fill( tick , tick+N , -1 );
	for( int i = 1 ; i <= N ; ++i ) parent[i]=i;
}

int main()
{
	int n,m;
	while( ~scanf("%d%d",&n,&m) ){
		init();
		int a,b,tot=0,re=0;
		for( int i = 0 ; i < m ; ++i ){
			scanf("%d%d",&a,&b);
			++rec[a];++rec[b];
			merge(a,b);
		}
		for( int i = 1 ; i <= n ; ++i ){
			if( parent[i] == i ){
				++re;tick[i] = 0;
			}
		}
		for( int i = 1 ; i <= n ; ++i ){
			int p = find(i);
			++ret[p];
			if( rec[i]%2 != 0 ) ++tick[p];
		}
		for( int i = 1 ; i <= n ; ++i ){
			if( tick[i] == -1 ) continue;
			if( tick[i] == 0 && ret[i] != 1 ) ++tot;
			tot += tick[i]/2;
		}
		printf("%d\n",tot);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值