Ant Trip (一笔画问题)

Ant Country consist of N towns.There are M roads connecting the towns. 

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal. 
InputInput contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.OutputFor each test case ,output the least groups that needs to form to achieve their goal.Sample Input
3 3
1 2
2 3
1 3

4 2
1 2
3 4
Sample Output
1
2


        
  
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town.
In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3.
In sample 2,tony and his friends must form two group.


题意:

给你无向图的N个点和M条边,保证这M条边都不同且不会存在同一点的自环边,现在问你至少要几笔才能所有边都画一遍.(一笔画的时候笔不离开纸)

思路:其实就是判断连通分量的个数,然后在对每个连通分量做具体判断:

(1)如果该连通分量是一个孤立的点,即num[i]==0或num[i]==1的时候,注意num[i]==0表示i不是根节点,num[i]==1表示的是独立的点。

(2)如果该连通分量是欧拉图或半欧拉图,那么只需要1笔即可,即num[i]>1且odd[i]==0的时候,表示是(半)欧拉图。

(3)如果该连通分量不是一个欧拉图时,那么我们需要奇数度点个数/2,证明可见:点击打开链接。即num[i]>1且odd[i]>0时需要odd[i]/2笔。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm> 
#include <cstring>
#include <vector>
#include <cmath>
#include <queue>
#include <stack> 
#define ll long long
#define maxn 100000+10
using namespace std;
int n,m;
int degree[maxn] ;
int fa[maxn];
int num[maxn];  //num[i]==x表示以i为根的连通分量有x个结点。
int odd[maxn];//奇度结点个数
int ans;
int findset(int i){  //并查集
	if(fa[i]==-1) return i;
    return fa[i]=findset(fa[i]);
	
}


int main(){
	while(scanf("%d%d",&n,&m)==2){
		ans=0;
		memset(degree,0,sizeof(degree));
		memset(fa,-1,sizeof(fa));
		memset(num,0,sizeof(num));
		memset(odd,0,sizeof(odd));
		for(int i=1;i<=m;i++){
			int u,v;
			scanf("%d%d",&v,&u);
			degree[u]++;
			degree[v]++;
			u=findset(u);
			v=findset(v);
			if(u!=v) fa[u]=v;
		}
		for(int i=1;i<=n;i++){
			num[findset(i)]++; 
			if(degree[i]%2) odd[findset(i)]++;
		}
		
		for(int i=1;i<=n;i++){  //三种情况
			if(num[i]<=1) continue;
			else if(odd[i]==0) ans+=1;
			else if(odd[i]>0) ans+=odd[i]/2;
		}
		printf("%d\n",ans);
	}
	return 0;
}



地址:点击打开链接

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值