hdu1505—City Game(1506的加强版)

题目链接:传送门

City Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7143    Accepted Submission(s): 3097


Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.
 

Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.
 

Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.
 

Sample Input
  
  
2 5 6 R F F F F F F F F F F F R R R F F F F F F F F F F F F F F F 5 5 R R R R R R R R R R R R R R R R R R R R R R R R R
 

Sample Output
  
  
45 0

题目大意:在给出的矩形图中的F区域内画一个最大的矩形

解题思路:要求该矩形,得确定矩形的位置,矩形的底边肯定是以整个矩形图中的某一行为底的,然后求出以该第向上延伸的高(即能够画矩形的区域),就变成了hdu1506的情况下所求矩形最大面积。

hdu1506的题解


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
using namespace std;

typedef long long ll;
typedef pair<int,int>PA;
const int N = 1009;
const int M = 30009;
const int INF = 0x3fffffff;

stack<PA>st;
int L[N],R[N],H[N][N];
//L[i]:第i个数左侧连续的数中第一个比data[i]大的数
//R[i]:第i个数右侧连续的数中第一个比data[i]大的数
//H[i]:第i个柱子的高度
//二维转一维,以第i行为底,求出H[i],然后求出最大的矩形面积

//n行,m列
int getMax( int n , int m )
{
    while( !st.empty() ) st.pop();
    L[1] = 1; st.push(PA(1,H[n][1]));
    for( int i = 2 ; i <= m; ++i ){
        int flag = 0;
        while( !st.empty() ){
            PA s = st.top();
            //找到左边连续的序列中第一个比data[i]大的数
            if( s.second < H[n][i] ){
                L[i] = s.first+1;
                flag = 1;
                st.push(PA(i,H[n][i]));
                break;
            }else{
                L[i] = L[s.first];
                st.pop();
            }
        }
        if( !flag ) st.push(PA(i,H[n][i]));
    }
    while( !st.empty() ) st.pop();
    R[m] = m; st.push(PA(m,H[n][m]));
    for( int i = m-1 ; i >= 1 ; --i ){
        int flag = 0;
        while( !st.empty() ){
            PA s = st.top();
            //找到右边连续的序列中第一个比data[i]大的数
            if( s.second < H[n][i] ){
                R[i] = s.first-1;
                flag = 1;
                st.push(PA(i,H[n][i]));
                break;
            }else{
                R[i] = R[s.first];
                st.pop();
            }
        }
        if( !flag ) st.push(PA(i,H[n][i]));
    }
    int ans = 0;
    for( int i = 1 ; i <= m ; ++i ){
        ans = max( ans , (R[i]-L[i]+1)*H[n][i] );
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while( T-- ){
        memset( H , 0 , sizeof(H) );
        int n,m;
        char ch;
        scanf("%d%d",&n,&m);
        for( int i = 1 ; i <= n ; ++i ){
            for( int j = 1 ; j <= m ; ++j ){
                scanf(" %c",&ch);
                if( ch == 'F' ) H[i][j] += H[i-1][j]+1;
                else H[i][j] = 0;
            }
        }
        int ans = 0;
        //对每一行为底的矩形图求最大矩形的面积
        for( int i = 1 ; i <= n ; ++i ){
            ans = max( ans , getMax( i , m ) );
        }
        printf("%d\n",ans*3);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值