hdu1045—Fire Net(二分图最大匹配)

题目链接:传送门

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12228    Accepted Submission(s): 7379


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
 
 
4.X......XX......2XX.X3.X.X.X.X.3....XX.XX4................0
 

Sample Output
 
 
51524


解题思路:弱弱的我听到大佬们说这题可以用二分匹配做,便思考着怎么个匹配法,然鹅什么也没想到,最后看了下大佬们的思路才写出来。对于每一列相连的点(没有‘X’的点)看做是一个点,标号为ri。对于每一行相连的点(没有‘X’的点)看做是一个点,标号为ci。对于图中的某个点处放一个‘O’,可以看成是ri和ci的匹配。即此时ri所代表的行区域和ci所代表的列区域不能再放任何的‘O’。即问题变成了求ri和ci所能匹配的最大数目


#include <iostream>
#include <cstring>
#include <stdio.h>

using namespace std;
#define size1 1006
#define size2 505

//对于每一列相连的点(没有‘X’的点)看做是一个点,标号为ri
//对于每一列相连的点(没有‘X’的点)看做是一个点,标号为ci
//对于图中的某个点处放一个‘O’,可以看成是ri和ci的匹配
//即此时ri所代表的行区域和ci所代表的行区域部能再放任何的‘O’
//即问题变成了求ri和ci所能匹配的最大数目

struct Edge
{
    int node;
    Edge*next;
}m_edge[size1];
int girl[size2];
Edge*head[size2];
int Flag[size2];
int Ecnt,cnt;

void init()
{
    Ecnt = cnt = 0;
    fill( girl , girl+size2 , 0 );
    fill( head , head+size2 , (Edge*)0 );
}

//b能和g匹配
void mkEdge( int b , int g )
{
    m_edge[Ecnt].node = g;
    m_edge[Ecnt].next = head[b];
    head[b] = m_edge+Ecnt++;
}

bool find( int x )
{
    for( Edge*p = head[x] ; p ; p = p->next ){
        int s = p->node;  //有好感的女生
        if( !Flag[s] ){
            Flag[s] = true;    //该女生在本轮匹配中被访问
            if( girl[s] == 0 || find(girl[s]) ){
                //女生没有对象或者另外一个男生能把这个妹子让给x男
                girl[s] = x;
                return true;
            }
        }
    }
    return false;
}

int solve( int n )
{
    for( int i = 1 ; i <= n ; ++i ){
        fill( Flag , Flag+size2 , 0 );
        if( find(i) ) ++cnt;
    }
    return cnt;
}

char graph[5][5];
int tickr[5][5],tickc[5][5]; //标记行列缩点后的序号

int Build( int n )
{
    int rec = 0;
    memset( tickr , 0 , sizeof(tickr) );
    memset( tickc , 0 , sizeof(tickc) );
    for( int i = 0 ; i < n ; ++i ){
        for( int j = 0 ; j < n ; ++j ){
            if( graph[i][j] == 'X' ) continue;
            tickr[i+1][j+1] = (tickr[i+1][j]==0)?(++rec):tickr[i+1][j];
        }
    }
    rec = 0;
    for( int j = 0 ; j < n ; ++j ){
        for( int i = 0 ; i < n ; ++i ){
            if( graph[i][j] == 'X' ) continue;
             tickc[i+1][j+1] = (tickc[i][j+1]==0)?(++rec):tickc[i][j+1];
             //if( tickr[i+1][j] != 0 )
             mkEdge(tickc[i+1][j+1],tickr[i+1][j+1]);
        }
    }
    return rec;
}

int main()
{
    int n;
    while( ~scanf("%d",&n)&&n ){
        init();
        for( int i = 0 ; i < n ; ++i ) scanf("%s",graph[i]);
        int s = Build(n);
        printf("%d\n",solve(s));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值