poj1523—SPF(tarjan算法求无向图中所有的割点)

题目链接:传送门

SPF
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9167 Accepted: 4152

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets


解题思路:无向图中求所有割点的tarjan算法模板


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <stack>
#include <queue>
#include <set>

using namespace std;

typedef long long ll;
const int N = 40900;
const int M = 1090;
const int INF = 0x3fffffff;
const double eps = 1e-8;
const double PI = acos(-1.0);

//low[u]是从u或者u的子孙出发通过回边可以到达的最低深度优先数
//low[u] = min{ dfn[u] ,
//              min{ low[w] | w是u的一个子女 } ,
//              min{ dfn[v] | v与u邻接,且(u,v)是一条回边} }

/*
    u是割点的充要条件
    u是深度优先搜索生成树的根,则u至少有两个子女
    u不是生成树的根,但他有个子女w,使得low[w]>=dfn[u]

    去掉割点u后,分成几个联通分量
    u是根节点,联通分量个数就是子女个数
    u不是根节点,若有d个子女w,使得low[w]>=dfn[u],去掉点u,分成d+1个联通分量
*/

//向下搜索时,如果顶点v是u的相邻顶点,若v还未被访问,则v是u的儿子节点
//若v被访问了,则v是u的祖先节点,且(u,v)是一条回边

struct Edge{
    int node;
    Edge*next;
}m_edge[N];
Edge*head[M];
int low[M],dfn[M],Flag[M],Ecnt,cnt;
int subnet[M],son,r;
//son记录根节点的子树个树,r为根节点
//subnet记录对于节点u的子节点v,low[v]>=dfn[u]的个数

void init()
{
    r = 1;
    Ecnt = cnt = son = 0;
    fill( subnet , subnet+M , 0 );
    fill( Flag , Flag+M , 0 );
    fill( head , head+M , (Edge*)0 );
}

void mkEdge( int a , int b )
{
    m_edge[Ecnt].node = b;
    m_edge[Ecnt].next = head[a];
    head[a] = m_edge+Ecnt++;
}

void tarjan( int u , int father )
{
    Flag[u] = 1;
    low[u] = dfn[u] = cnt++;
    for( Edge*p = head[u] ; p ; p = p->next ){
        int v = p->node;
        if( !Flag[v] ){
            tarjan(v,u);
            low[u] = min(low[u],low[v]);
            if( low[v] >= dfn[u] ){
                if( u != r ) subnet[u]++;
                else son++;
            }
        }
        //v是u的祖先,且(u,v)是一条回边
        if( Flag[v] && v != father )
            low[u] = min(low[u],dfn[v]);
    }
}

int main()
{
    int n,m,cas = 0;
    while( ~scanf("%d",&n)&&n ){
        scanf("%d",&m);
        init();
        int node = 0;
        node = max(node,max(m,n));
        mkEdge(n,m);
        mkEdge(m,n);
        while(1){
            scanf("%d",&n);
            if( n == 0 ) break;
            scanf("%d",&m);
            node = max(node,max(m,n));
            mkEdge(m,n);
            mkEdge(n,m);
        }
        tarjan(r,-1);
        if( cas != 0 ) printf("\n");
        printf("Network #%d\n",++cas);
        if( son >= 2 ) subnet[1] = son-1;
        int flag = 0;
        for( int i = 1 ; i <= node ; ++i ){
            if( subnet[i] >= 1 ){
                flag = 1;
                printf("  SPF node %d leaves %d subnets\n",i,subnet[i]+1);
            }
        }
        if( !flag )  printf("  No SPF nodes\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值