POJ - 1523 SPF(tarjan求割点+求连通分量个数)

题目链接:https://vjudge.net/problem/POJ-1523

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.
在这里插入图片描述
Input
The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.
Output
For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as “Network #1”, the second as “Network #2”, etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text “No SPF nodes” instead of a list of SPF nodes.
Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

翻译:
每个样例每一对整数表示直接相连的结点,无向边,组成一个网络。每个网络的数据中的最后一行为一个0,表示结束。整个输入文件最后一行为一个0,代表输入结束。
SPF结点:对于一个连通的网络,如果一个结点出现故障,将会阻止至少一对结点之间的通信,则该结点是SPF结点。
对于每一个SPF结点,输出结点序号及该SPF结点去掉后将整个网络分为几个连通的子网络。
分析:
对于SPF结点即割点,用tarjan算法。
求出一个割点后,去掉该节点u,将原来的连通图分成了几个连通分量?
知识点:
(1)如果割点u是根节点,则有几个子女,就分成了几个连通分量。
(2)如果割点u不是根节点,如果有d个子女w,使得low[w]>=dfn[u],则去掉该节点,分成了d+1个连通分量。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<stdlib.h>
using namespace std;
const int N=1e3+10;
int mp[N][N];
int low[N],dfn[N],dfstime;
int subnode[N],son,node;///记录每个结点(去掉该节点后)的连通分量个数
bool vis[N];
void init()
{
	memset(mp,0,sizeof(mp));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	dfstime=1;
	son=0;///子女的个数
	memset(subnode,0,sizeof(subnode));
	memset(vis,false,sizeof(vis));
	node=0;///记录最大的结点编号
	dfn[1]=low[1]=1;
	vis[1]=true;
}
void dfs(int u)
{
	for(int v=1; v<=node; v++)
	{
		if(mp[u][v]==1)
		{
			if(!vis[v])
			{
				vis[v]=true;
				dfstime++;
				dfn[v]=low[v]=dfstime;
				dfs(v);
				low[u]=min(low[u],low[v]);
				if(low[v]>=dfn[u])
				{
					if(u==1)
						son++;
					else
						subnode[u]++;
				}
			}
			else
				low[u]=min(low[u],dfn[v]);
		}
	}
}
int main()
{
	int u,v,num;
	num=0;///控制格式
	while(~scanf("%d",&u))
	{
		init();
		if(u==0)
			break;
		node=max(node,u);
		scanf("%d",&v);
		node=max(node,v);
		mp[u][v]=1;
		mp[v][u]=1;
		while(1)
		{
			scanf("%d",&u);
			node=max(node,u);
			if(u==0)
				break;
			scanf("%d",&v);
			node=max(node,v);
			mp[u][v]=1;
			mp[v][u]=1;
		}
		if(num!=0)
			printf("\n");
		num++;
		printf("Network #%d\n",num);
		dfs(1);
		if(son>1)
			subnode[1]=son-1;
		bool find=false;
		for(int i=1; i<=node; i++)
		{
			if(subnode[i])
			{
				find=true;
				printf("  SPF node %d leaves %d subnets\n",i,subnode[i]+1);
			}
		}
		if(!find)
			printf("  No SPF nodes\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zaiyang遇见

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值