poj3281——Dining(最大流)

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7161 Accepted: 3272
Description


Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.


Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.


Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.


Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).


Input


Line 1: Three space-separated integers: N, F, and D 
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.
Output


Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input


4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output

3
Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.
Source

USACO 2007 Open Gold

解析:

           此题构网络流的方法很特别。。。

           很多人都能想到此题要构建三个点集:分别是食物,奶牛和饮料。。。然后连超级源和超级汇。。。最后求最大流

           但其实这是有问题的,因为每头奶牛只能对应一种饮料和食物。。。所以奶牛和饮料,奶牛和食物都需要一一对应。。。

           所以需要构建两个二分图,即把中间的奶牛的点一分为二。。。在拆开的两个点之间连容量为一的边。。。

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

const int inf=1000000;
int map[410][410],n,m,k,l=0,tol;
struct node
{
    int u,v,c,next;
}edge[8000];
int head[810],sumd[810],d[810];

void addedge(int u,int v,int c)
{
    edge[l].u=u;
    edge[l].v=v;
    edge[l].c=c;
    edge[l].next=head[u];
    head[u]=l++;
    edge[l].u=v;
    edge[l].v=u;
    edge[l].c=0;
    edge[l].next=head[v];
    head[v]=l++;
}

void readdata()
{
    freopen("poj3281.in","r",stdin);
    freopen("poj3281.out","w",stdout);
    scanf("%d%d%d",&n,&m,&k);
    for(int i=1;i<=n;i++)
    {
        int f,d;
        scanf("%d%d",&f,&d);
        for(int j=1;j<=f;j++)
        {
            int ff;
            scanf("%d",&ff);
            map[ff][i+m]=1;
        }
        for(int j=1;j<=d;j++)
        {
            int dd;
            scanf("%d",&dd);
            map[i+m+n][2*n+m+dd]=1;
        }
    }
    for(int i=1;i<=m;i++)
        map[0][i]=1;
    for(int i=2*n+m+1;i<=2*n+m+k;i++)
        map[i][2*n+m+k+1]=1;
    for(int i=m+1;i<=m+n;i++)
        map[i][i+n]=1;
}

int max_flow(int u,int flow)
{
    if(u==tol)return flow;
    int sum=0;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(edge[i].c && d[u]==d[v]+1)
        {
            int t=max_flow(v,min(flow-sum,edge[i].c));
            sum+=t;
            edge[i].c-=t;
            edge[i^1].c+=t;
            if(sum==flow)return sum;
        }
    }
    if(d[0]>=tol+1)return sum;
    sumd[d[u]]--;
    if(sumd[d[u]]==0)d[0]=tol+1;
    sumd[++d[u]]++;
    return sum;
}

void work()
{
    tol=2*n+m+k+1;
    memset(head,255,sizeof(head));
    for(int i=0;i<=tol;i++)
        for(int j=0;j<=tol;j++)
        {
            if(map[i][j])
            {
                //cout<<i<<' '<<j<<' '<<map[i][j]<<endl;
                addedge(i,j,map[i][j]);
                }
        }
    sumd[0]=tol+1;
    int ans=0;
    while(d[0]<=tol)
    {
        ans+=max_flow(0,2*inf);
    }
    cout<<ans<<endl;
}

int main()
{
    readdata();
    work();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值