poj3281——Dining(网络流+拆点)

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.
Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output

3
Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

每个牛有一些喜欢的食物和饮料,农夫做了f种食物和d种饮料,每种食物和饮料只能给一个牛,求最多能有多少个牛能吃到东西
一开始总以为是二分匹配,其实有个用网络流的巧妙方法,设源点为食物,汇点为饮料,牛就在中间,为了防止一个牛吃到多个食物,将牛拆成左右两点,两点之间容量为1,这样就能保证最后在汇点的每个流都只经过一个牛

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
//#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 10005
#define Mod 10001
using namespace std;
int n;
int flow[MAXN][MAXN],cap[MAXN][MAXN],pre[MAXN],a[MAXN]; //流量,容量,父节点,残量
void EdmondsKarp(int s,int t)
{
    int u,v;
    queue<int> q;
    int f=0;
    while(1)
    {
        memset(a,0,sizeof(a));
        q.push(s);
        a[s]=INF;
        while(!q.empty()) //bfs找增光路径
        {
            u=q.front();
            q.pop();
            for(v=0; v<=n+1; ++v)
            {
                if(a[v]==0&&cap[u][v]>flow[u][v])
                {
                    pre[v]=u;
                    a[v]=min(a[u],cap[u][v]-flow[u][v]); //找到s-v路径的最小残量
                    q.push(v);
                }
            }
        }
        if(a[t]==0) //所有路径的残量都为0,说明已经是最大流
            break;
        for(v=t; v!=s; v=pre[v]) //更新路径的流量
        {
            flow[pre[v]][v]+=a[t];
            flow[v][pre[v]]-=a[t];
        }
        f+=a[t];
    }
    printf("%d\n",f);
}
int main()
{
    int N,D,F;
    while(~scanf("%d%d%d",&N,&F,&D))
    {
        //0是源点,1-F是食物,F+1-F+N是牛左点,F+N+1-F+N+N是牛右点,F+N+N+1-F+N+N+D是drink饮料点,F+N+N+D+1是汇点
        for(int i=1;i<=F;++i)
            cap[0][i]=1; //从源点到食物
        for(int i=F+N+N+1;i<=F+N+N+D;++i)
            cap[i][F+N+N+D+1]=1; //从饮料到汇点
        for(int i=F+1;i<=F+N;++i)
            cap[i][i+N]=1; //从左牛点到右牛点
        n=F+N+N+D;
        for(int i=1;i<=N;++i)
        {
            int f,d,id;
            scanf("%d%d",&f,&d);
            while(f--)
            {
                scanf("%d",&id);
                cap[id][i+F]=1; //从食物到左牛点
            }
            while(d--)
            {
                scanf("%d",&id);
                cap[i+F+N][id+F+N+N]=1; //从右牛点到饮料
            }
        }
        EdmondsKarp(0,n+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值