hdu3555——Bomb(数位DP)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 3212    Accepted Submission(s): 1142

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 
Output
For each test case, output an integer indicating the final points of the power.
 
Sample Input
3
1
50
500
 
Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.
 
Author
fatboy_cw@WHU

Source
2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

Recommend

zhouzeyong

解析: 

         和hdu2089一样,就不多说了。。。

         很基础的数位DP

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
//dp[i][0]没有出现49
//dp[i][1]没有出现49且最高位为9
//dp[i][2]出现了49
long long dp[21][3];

void init()
{
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=1;i<20;i++)
    {
        dp[i][0]=(long long)dp[i-1][0]*10-dp[i-1][1];
        dp[i][1]=dp[i-1][0];
        dp[i][2]=dp[i-1][1]+(long long)dp[i-1][2]*10;
    }
}

void read()
{
    freopen("hdu3555.in","r",stdin);
    freopen("hdu3555.out","w",stdout);
    int test;
    scanf("%d",&test);
    while(test--)
    {
        long long x;
        scanf("%I64d",&x);
        x++;
    	long long y=x;  int l=0;   int wei[30];
    	bool flag=0;
    	while(y)
   	    {
        	wei[++l]=(y%10);
       		y/=10;
    	}
    	long long ret=0;
    	wei[l+1]=0;
    	for(int i=l;i>=1;i--)
    	{
        	ret+=(long long)dp[i-1][2]*wei[i];
        	if(flag)ret+=dp[i-1][0]*wei[i];
        	if(!flag&&wei[i]>4)ret+=dp[i-1][1];
        	if(wei[i+1]==4&&wei[i]==9)flag=true;
    	}
    	printf("%I64d\n",ret);
    }
}

int main()
{
    init();
    read();
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值