Conquer a New Region (并查集)hdu 4424

The wheel of the history rolling forward, our king conquered a new region in a distant continent. 
There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route. 
Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases. 
The first line of each case contains an integer N. (1 <= N <= 200,000) 
The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 <= a, b <= N, 1 <= c <= 100,000) 

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output

4
3

 

 

好久才明白题意。。。。。。。。。。。。、

就是给你n个城市和(n-1)条路,每条i直接路径包含起点a   终点 b  最大运输能力c    , 城市 i 到 城市j的最大运输量就是从i到j中所经路途中所以最大运输量的最小值,然后寻找一个中心点,使其到其他( n-1)个城市的总运输量最大。( 如果还没明白  我们配个图 hhhhhhhhhh)

 

如上图 ,6个顶点 ,5条路, 假设以6为中心,6到1所经路径中的运输量依次为 5, 2 ,1 , 所以城市6到城市1的最大运输量为1

以此类推。

 

 

做法:根据边权从大到小排序, 每次合并最大边权的两个点。  两个点各在一个集合,rankk表示这个集合有多少点,sum表示这个集合内部 某个点 到其他所有点的路径上的最小边权 的最大和。u_是u 所在集合的祖先,如果以u_为合并后的祖先,那么把sum[u_]更新为两个集合的点和,当前枚举的边肯定比之前的边要小,所以 sum[u_] = rankk[v_]*w+sum[u_]。把 以v_为祖先 所得的答案作比较, 取答案较大的那个点做为祖先。不断合并,最后形成的集合的 sum就是答案了。
 

 

 

 

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
using namespace std;
#define ma 200005
typedef long long ll;


ll pa[ma];
ll rankk[ma];          ///rankk[i] i为根的树的结点个数
ll sum[ma]; ///sum[i]  以i为中心点集合的最大运输量

struct node
{
    int f;
    int t;
    int len;
} e[ma];

ll findd( ll x )
{
    if( x ==  pa[x] )
    {
        return pa[x];
    }
    else
    return pa[x] =  findd( pa[x] );
}


ll unionn( int x, int y ) ///pyÊÇÀÏ´ó
{
    ll px = findd( x );
    ll py = findd( y );
    if( px != py )
    {
        pa[px] = py;
        rankk[py] += rankk[px];
    }
    return 1;
}


bool cmp( node x, node y )
{
    return x.len > y.len;
}


int main()
{
    ll t ,n , i;
    ll a, b, c;
    while(  scanf("%lld", &n) != EOF )
    {
        memset( e, 0, sizeof( e ));
        for( i = 0; i<=n+5; i++)
        {
            pa[i] = i;
            sum[i] = 0;
            rankk[i] = 1;
        }
        for( i = 0; i<n-1; i++)
        {
            scanf("%d%d%d", &a, &b, &c);
            e[i].f = a;
            e[i].t = b;
            e[i].len = c;
        }

        sort( e, e + n-1, cmp);
        ll s1,s2;
        ll ans;
        for( i = 0; i<n-1; i++)
        {
            a = findd(e[i].f) ;
            b = findd(e[i].t);
            c = e[i].len;
            if( a !=  b)
            {
                s1 = sum[a] + rankk[b] *c;
                s2 = sum[b] + rankk[a] *c;
                ans = max( s1, s2 );
            }
            if( s1 > s2 )
            {
                sum[a] = s1;
                unionn( b, a);
            }
            else
            {
                sum[b] = s2;
                unionn( a, b );
            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}

一个集合中以祖先为中心点的sum最大

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值