03-树3 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 3030) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to NN). Then 2N2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1


已知先序遍历和中序遍历求后序遍历,不用建树的方法

package mooc.map;

import java.util.Scanner;
import java.util.Stack;

public class Main {
	private static int[] pre;
	private static int[] in;
	private static int[] post;
	public static void main(String[] args) {
		Stack<Integer> stack = new Stack<Integer>();
		Scanner scan = new Scanner(System.in);
		int N = scan.nextInt();
		pre = new int[N];
		in = new int[N];
		post = new int[N];
		int prePoint = 0;
		int inPoint = 0;
		while (scan.hasNext()) {
			String str = scan.next();
			if (str.equals("Push")) {
				int num = scan.nextInt();
				stack.push(num);
				pre[prePoint++] = num;
			} else if (str.equals("Pop")) {
				in[inPoint++] = stack.pop();
			}
		}
		
		slove(0,0,0,N);
		String str = "";
		for(int i=0;i<N;i++){
			str+=post[i]+" ";
		}
		System.out.println(str.trim());
	}
	
	public static void slove(int preL,int inL,int postL,int n){
		if(n==0){
			return;
		}
		if(n==1){
			post[postL] = pre[preL];
			return;
		}
		int root = pre[preL];
		post[postL+n-1] = pre[preL];
		int i;
		for(i=0;i<n;i++){
			if(in[inL+i]==root){
				break;
			}
		}
		int L = i,R = n - i -1;
		slove(preL+1,inL,postL,L);
		slove(preL+L+1,inL+L+1,postL+L,R);
	}
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值