1086 Tree Traversals Again (25分) 树的遍历(中序+前序写后序)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1
#include <iostream>
#include <vector>
#include <string>
#include <stack>

using namespace std;

stack<int> s;
vector<int> pre, in, post, value;

void postOrder(int root,int start,int end)
{
	if (start>end)
	{
		return;
	}
	int i = start;
	while (i<end&&pre[root]!=in[i])
	{
		i++;
	}
	postOrder(root + 1, start, i - 1);
	postOrder(root + 1 + i - start, i + 1, end);
	post.push_back(pre[root]);
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	
	string str;
	int index = 0;//为了应对有的值相同的情况,用下标代表,输出时直接去value里取值。
	str.resize(6);//先确定string的长度才能用scanf输入
	while (~scanf("%s",&str[0]))
	{
		if (str[1]=='u')
		{
			int temp;
			cin >> temp;
			value.push_back(temp);
			pre.push_back(index);
			s.push(index++);
		}
		else
		{
			in.push_back(s.top());
			s.pop();
		}
	}
	postOrder(0, 0, n - 1);
	cout << value[post[0]];
	for (int i = 1; i < n; i++)
	{
		cout << " " << value[post[i]];
	}
	return 0;
}

 输入时:

如果写成:while (scanf("%s",&str[0])) 会使得所有测试点超时:

而while(-1),会一直执行while语句,陷入死循环。

另种写法while (scanf("%s",&str[0])!=EOF)也是没问题的:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值