【PAT】1036 Boys vs Girls (25分) (比较 模拟)

题目:

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

 

题目大意:求出男(male)生中最低成绩,并求出女生(female)中最高成绩,求出他们的差值,缺少男或女输出Absent,NA;

(一开始把男女的英文搞错了也是很尴尬...)

输入:N(输入人数),后面n行,每行内容包括:namegenderID , grade,

输出:女生最高的name和id,男生最高的name和id,差值(分三行)

若其中一种性别没有就输出absent 最后输出na

解题思路:遇到比较的题一般按行处理,逐个比较,用变量记录下需要相关输出的即可。

代码:

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
  string name,gender,id,maxname,minname,maxid,minid;
  int grade,max=-1,min=101;
  //freopen("input.txt","r",stdin); 
  int n;
  cin>>n;
  bool flagM=false;
  bool flagF=false;
  while(n--){
    cin>>name>>gender>>id>>grade;
    if(gender=="F"){
      if(grade>max){
        max=grade;
        maxname=name;
        maxid=id;
        
      }flagF=true;
    }else if(gender=="M"){
      if(grade<min){
        min=grade;
      	minname=name;
      	minid=id;
      	
      }flagM=true;

    }
  }
  if(max != -1)
        cout<<maxname<<" "<<maxid<<endl;
    else
        printf("Absent\n");
    if(min != 101)
        cout<<minname<<" "<<minid<<endl;
    else
        printf("Absent\n");
    if(max != -1 && min != 101)
        cout<<(max-min);
    else
        printf("NA");
  return 0;
}

这题我本来想用flag来标识是存在缺男生或者缺女生的情况,但是输出时总有一个测试点过不了,很想不通,参考了柳神的输出,感觉我们的逻辑是一样的,给出代码如下,如果有大佬看出问题所在,欢迎指教!

if((!flagM)&&(flagF)){
  	cout<<"Absent"<<endl;
    cout<<maxname<<" "<<maxid<<endl<<"NA";
  	
    
  }
  else if((flagM)&&(!flagF)){
	cout<<"Absent"<<endl;
    cout<<minname<<" "<<minid<<endl<<"NA";
  }
   else if((!flagM)&&(!flagF)){
	cout<<"Absent"<<endl;
    cout<<"Absent"<<endl<<"NA";
  }
  else{
    cout<<maxname<<" "<<maxid<<endl;
    cout<<minname<<" "<<minid<<endl;
    cout<<(max-min);
  }

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值