【PAT】1005 Spell It Right (20分)(模拟 字符串处理)

题目:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​^100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题目大意:给出一行数字,计算他们的和并将和以英文形式输出;

解题思路:我之前采用的是转成整数再一位一位取下来计算的方式,后来发现题目所给的要求是10^100范围的数,就直接用字符串加了,还更方便点(擦汗)

代码:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int main(){
  string num;
  
  //freopen("input.txt","r",stdin);
  cin>>num;
  if(num=="0")cout<<"zero";
  else{
//	  long long res=stoll(num);
//	  int sum=0;
//	  while(res!=0){
//	    sum+=res%10;
//	    res/=10;
//	  }起先没考虑范围,测试时候出现两个运行时错误, 报错是stoi,
//改为stoll之后测试还有一个运行错误, 后来发现longlong只有十进制下的19位左右,
//所以只能改用其他方法,如下:
	int sum = 0;
    for (int i = 0; i < num.length(); i++){
		sum += (num[i] - '0'); 
	}
        
	  string s[]={"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
	  string ans=to_string(sum);
	  
	  for(int i=0;i<ans.size();i++){
	    if(i!=0)cout<<" ";
	      cout<<s[ans[i]-'0']; 
	  }
	}
  
  
  return 0;
}

其他优秀代码:

昵称五个字:用到了递归;

https://blog.csdn.net/a617976080/article/details/89089570

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
string a[] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
// 如果取余一次输出一个余数,那么与正确的结果正好是返过来的, 所以使用dfs反向输出
void f(int n){
    int next = n / 10;
    if(next > 0){
        f(next);
        printf("%c", ' ');
    }
    cout << a[n % 10];
}
int main(int argc, const char * argv[]) {
    int n = 0;
    string s;
    cin >> s;
    const unsigned long l = s.size();
    for(int i = 0; i < l; i++){
        n += s[i] - '0';
    }
    
    // 这里注意处理n为0的情况,否则会有一个点过不了
    if(n == 0) printf("zero");
    else f(n);
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值