Rob Kolstad
Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.
Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.
Print both the number and its square in base B.
PROGRAM NAME: palsquare
INPUT FORMAT
A single line with B, the base (specified in base 10).SAMPLE INPUT (file palsquare.in)
10
OUTPUT FORMAT
Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.SAMPLE OUTPUT (file palsquare.out)
1 1 2 4 3 9 11 121 22 484 26 676 101 10201 111 12321 121 14641 202 40804 212 44944 264 69696
#include <fstream>
using namespace std;
int main(int argc, const char * argv[])
{
ofstream fout("palsquare.out");
ifstream fin("palsquare.in");
int zs_hexConversion(const int& num,const int &zs_hex,char *zsNum);
bool zs_isPalindrome(int num,const char* zsNum);
char zs_NUM[2048];
char zs[1024];
int zs_hex;
fin>>zs_hex;
for(int i=1;i<=300;i++)
{
if(zs_isPalindrome(zs_hexConversion(i*i,zs_hex,zs_NUM),zs_NUM))
{
int length = zs_hexConversion(i,zs_hex,zs);
length--;
for(;length>=0;length--)
fout<<zs[length];
fout<<" "<<zs_NUM<<endl;
}
}
return 0;
}
int zs_hexConversion(const int& num,const int &zs_hex,char *zsNum)
{
int tempN;
int _num = num;
int i=0;
for (;_num!=0;i++)
{
tempN = _num%zs_hex;
_num=_num/zs_hex;
if(tempN>=10)
{
tempN = tempN - 10;
zsNum[i]=('A'+tempN);
}
else
{
zsNum[i]=('0'+tempN);
}
}
zsNum[i]='\0';
return i;
}
bool zs_isPalindrome(int num,const char* zsNum)
{
num--;
for(int i=0;i<num;i++,num--)
{
if(zsNum[i]!=zsNum[num])
return false;
}
return true;
}
这道题唯一的知识点就是数制的转换。
思路:好像没什么难的,主要就是考进制转换,以及回文数的判断。这里要注意,最大的20进制中19表示为J,不要只CASE到15哦!
穷举1~300的所有平方数,转进制,比较,OK了,除非你不会怎么转进制。短除,然后逆序输出。
结果:
USER: jim zhai [jszhais1] TASK: palsquare LANG: C++ Compiling... Compile: OK Executing... Test 1: TEST OK [0.000 secs, 3356 KB] Test 2: TEST OK [0.000 secs, 3356 KB] Test 3: TEST OK [0.000 secs, 3356 KB] Test 4: TEST OK [0.000 secs, 3356 KB] Test 5: TEST OK [0.000 secs, 3356 KB] Test 6: TEST OK [0.000 secs, 3356 KB] Test 7: TEST OK [0.000 secs, 3356 KB] Test 8: TEST OK [0.000 secs, 3356 KB] All tests OK.Your program ('palsquare') produced all correct answers! This is your submission #2 for this problem. Congratulations!
Here are the test data inputs:
------- test 1 ---- 10 ------- test 2 ---- 2 ------- test 3 ---- 5 ------- test 4 ---- 11 ------- test 5 ---- 15 ------- test 6 ---- 18 ------- test 7 ---- 20 ------- test 8 ---- 3Keep up the good work!
#include <stdio.h> #include <stdlib.h> #include <string.h> #include <assert.h> #include <ctype.h> #include <math.h> /* is string s a palindrome? */ int ispal(char *s) { char *t; t = s+strlen(s)-1; for(t=s+strlen(s)-1; s<t; s++, t--) if(*s != *t) return 0; return 1; } /* put the base b representation of n into s: 0 is represented by "" */ void numbconv(char *s, int n, int b) { int len; if(n == 0) { strcpy(s, ""); return; } /* figure out first n-1 digits */ numbconv(s, n/b, b); /* add last digit */ len = strlen(s); s[len] = "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ"[n%b]; s[len+1] = '\0'; } void main(void) { char s[20]; char t[20]; int i, base; FILE *fin, *fout; fin = fopen("palsquare.in", "r"); fout = fopen("palsquare.out", "w"); assert(fin != NULL && fout != NULL); fscanf(fin, "%d", &base); for(i=1; i <= 300; i++) { numbconv(s, i*i, base); if(ispal(s)) { numbconv(t, i, base); fprintf(fout, "%s %s\n", t, s); } } exit(0); }