A Simple Problem with Integers POJ - 3468

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

AC的C++程序如下:

#include<cstdio>
using namespace std;
const int MAXN=1e5+10;
typedef long long ll;
ll sum[4*MAXN],add[4*MAXN];
void push_up(int rt){ //向上更新,通过当前节点rt把值递归到父节点 
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void push_down(int rt,int m){  //更新rt的子节点 
	if(add[rt]){
		add[rt<<1]+=add[rt];
		add[rt<<1|1]+=add[rt];
		sum[rt<<1]+=(m-(m>>1))*add[rt];
		sum[rt<<1|1]+=(m>>1)*add[rt];
		add[rt]=0;
	}
}
void build(int l,int r,int rt){
	add[rt]=0;
	if(l==r){
		scanf("%lld",&sum[rt]);
		return; 
	}
	int mid=(l+r)>>1;
	build(l,mid,rt<<1);
	build(mid+1,r,rt<<1|1);
	push_up(rt);
}
void update(int a,int b,ll c,int l,int r,int rt){
	if(a<=l&&b>=r){
		sum[rt]+=(r-l+1)*c;
		add[rt]+=c;
		return;
	}
	push_down(rt,r-l+1); //向下更新 
	int mid=(l+r)>>1;
	if(a<=mid) update(a,b,c,l,mid,rt<<1);
	if(b>mid) update(a,b,c,mid+1,r,rt<<1|1);
	push_up(rt); //向上更新 
}
ll query(int a,int b,int l,int r,int rt){
	if(a<=l&&b>=r) return sum[rt];
	push_down(rt,r-l+1);
	int mid=(l+r)>>1;
	ll ans=0;
	if(a<=mid) ans+=query(a,b,l,mid,rt<<1);
	if(b>mid) ans+=query(a,b,mid+1,r,rt<<1|1);
	return ans;
}
int main(){
   int n,m;
   scanf("%d%d",&n,&m);
   build(1,n,1);
   while(m--){
   	char str[2];
   	int a,b;long long c;
   	scanf("%s",str);
   	if(str[0]=='C'){
   		scanf("%d%d%lld",&a,&b,&c);
   		update(a,b,c,1,n,1); 
	   }else{
	   	scanf("%d%d",&a,&b);
	   	printf("%lld\n",query(a,b,1,n,1));
	   }
   }
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值