Farm Tour POJ - 2135 (最小费用最大流)

When FJ’s friends visit him on the farm, he likes to show them around. His farm comprises N (1 <= N <= 1000) fields numbered 1..N, the first of which contains his house and the Nth of which contains the big barn. A total M (1 <= M <= 10000) paths that connect the fields in various ways. Each path connects two different fields and has a nonzero length smaller than 35,000.

To show off his farm in the best way, he walks a tour that starts at his house, potentially travels through some fields, and ends at the barn. Later, he returns (potentially through some fields) back to his house again.

He wants his tour to be as short as possible, however he doesn’t want to walk on any given path more than once. Calculate the shortest tour possible. FJ is sure that some tour exists for any given farm.
Input
* Line 1: Two space-separated integers: N and M.

  • Lines 2..M+1: Three space-separated integers that define a path: The starting field, the end field, and the path’s length.
    Output
    A single line containing the length of the shortest tour.
    Sample Input
    4 5
    1 2 1
    2 3 1
    3 4 1
    1 3 2
    2 4 2
    Sample Output
    6

题意: 从1走到n,从n走到1,要求不走重边情况下的最小费用,因为不能走重边所以每个边的容量为1,费用为该路的长度,增加一个源点,汇点,因为一来回,所以1到源点,n到汇点的边,容量为2,费用为0,直接用紫书上的最小费用最大流模板做。
AC的C++程序如下:

#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
typedef long long ll;
struct edge
{
    int from, to, cap, flow, cost;
    edge(int u, int v, int c, int f, int w) :from(u), to(v), cap(c), flow(f), cost(w)
    {
    }
};
struct mcmf
{
    int n, m;
    vector<edge> edges;
    vector<int> g[maxn];
    int visit[maxn]; //是否在队列中
    int dist[maxn];
    int p[maxn]; //上一条弧
    int a[maxn]; //可改进的量
    void init(int n)
    {
        this->n = n;
        for (int i = 0; i <= n; i++) g[i].clear();
        edges.clear();
    }
    void addedge(int from, int to, int cap, int cost)
    {
        edges.push_back(edge(from, to, cap, 0, cost));
        edges.push_back(edge(to, from, 0, 0, -cost));
        m = edges.size();
        g[from].push_back(m - 2);
        g[to].push_back(m- 1);
    }
    bool bellmanford(int s, int t, int &flow,int &cost)
    {
        for (int i = 0; i <= n; i++) dist[i] = inf;
        memset(visit, 0, sizeof(visit));
        dist[s] = 0; visit[s] = 1; p[s] = 0; a[s] = inf;
        queue<int> q;
        q.push(s);
        while (!q.empty())
        {
            int u = q.front(); q.pop();
            visit[u] = 0;
            for (int i = 0; i < (int)g[u].size(); i++)
            {
                edge e = edges[g[u][i]];
                if (e.cap > e.flow&&dist[e.to] > dist[u] + e.cost)
                {
                    dist[e.to] = dist[u] + e.cost;
                    p[e.to] = g[u][i];
                    a[e.to] = min(a[u], e.cap - e.flow);
                    if (!visit[e.to]) q.push(e.to), visit[e.to] = 1;
                }
            }
        }
        if (dist[t] == inf) return false;
        flow += a[t];
        cost += dist[t] * a[t];
        for (int i = t; i != s; i = edges[p[i]].from)
        {
            edges[p[i]].flow += a[t];
            edges[p[i] ^ 1].flow -= a[t];
        }
        return true;
    }
    int mincostmaxflow(int s, int t, int &cost)
    {
        int flow = 0; cost = 0;
        while (bellmanford(s, t, flow, cost));
        return flow;
    }
};
int main()
{
       int n, m;
        cin >> n >> m;
        mcmf mc;
        mc.init(n + 1);
        int src, dest, cost;
        for (int i = 1; i <= m; i++)
        {
            cin >> src >> dest >> cost;
            mc.addedge(src, dest, 1, cost);
            mc.addedge(dest, src, 1, cost);
        }
        mc.addedge(0, 1, 2, 0);
        mc.addedge(n, n + 1, 2, 0);
        int  c = 0; 
        mc.mincostmaxflow(0, n+1, c);
        cout << c << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值