HDU--杭电1698--Just a Hook--线段树

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13930    Accepted Submission(s): 6893
Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
Now Pudge wants to do some operations on the hook. Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: For each cupreous stick, the value is 1. For each silver stick, the value is 2. For each golden stick, the value is 3. Pudge wants to know the total value of the hook after performing the operations. You may consider the original hook is made up of cupreous sticks.
 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 
Sample Input
   
   
1 10 2 1 5 2 5 9 3
 

Sample Output
   
   
Case 1: The total value of the hook is 24.
 
题意就是有棍子价值有1,2,3三种,初始是1,然后每次输入a,b,c是把a到b的棍子全部变成价值c,最后求总价值


#include <iostream>
#include <cstdio>
using namespace std;
int n,c;
struct node
{
    int l,r,c;	//左节点,右节点,当前价值
}s[1000000];
void setit(int l,int r,int step)	//建树
{
    s[step].l=l;
    s[step].r=r;
    s[step].c=1;
    if(l==r)return;
    int mid=(l+r)/2;
    setit(l,mid,2*step);
    setit(mid+1,r,2*step+1);
}
void insert(int l,int r,int step)	//l到r全部变为价值c
{
    if(c==s[step].c)return;	//如果当前节点的区间价值和c相同就直接结束
    if(s[step].l==l&&s[step].r==r){s[step].c=c;return;}	//如果找到了就替换价值之后结束
    if(s[step].c)s[2*step].c=s[2*step+1].c=s[step].c;	//不然把价值递归到左右子树
    s[step].c=0;	//并把当前接点价值归零,0作为特殊价值,就是为了上面那一句的判断,判断是否价值已经向下传递
    int mid=(s[step].l+s[step].r)/2;
    if(mid>=l&&mid<r)insert(l,mid,2*step),insert(mid+1,r,2*step+1);	//左右都有
    else insert(l,r,2*step+(mid<l?1:0));	//在左或在右
}
int print(int step)	//求价值和
{
    if(s[step].c)return (s[step].r-s[step].l+1)*s[step].c;	//有价值就返回价值
    return print(2*step)+print(2*step+1);	//不然就返回左右子树的回溯
}
int main(void)
{
    int t,m,i,j,k,l=1;
    scanf("%d",&t);
    while(t--&&scanf("%d",&n))
    {
        scanf("%d",&m);
        setit(1,n,1);
        while(m--&&scanf("%d%d%d",&i,&j,&c))
        insert(i,j,1);
        printf("Case %d: The total value of the hook is %d.\n",l++,print(1));
    }
    return 0;
}

	这个题就是向下递归那里的压缩比较经典,时间也就是那里节约的,如果当前节点区间内价值相同,就用同意的价值标记,不同的话就把它的价值弄成0,这样就好知道这里区间内价值有不同,同时把价值传递给左右子树后向下递归 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值