PKU 1287 Networking

初次编辑时间:2011-07-03

source page:http://poj.org/problem?id=1287

Networking
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6684 Accepted: 3636

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

Source

source code:

最小生成树(prim算法)

#include<stdio.h>
#define intmax 999999999 //定义无穷大
int cost[51];//记录已遍历的点到未遍历的点之间的最小权值
int dis[51][51];//记录两个点之间的距离
int main(){
    int i,j,a,b,k,n,m,min,sum;
    while(scanf("%d",&n)!=EOF&&n){
        scanf("%d",&m);
        //初始化dis数组
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
                dis[i][j]=intmax;
                
        while(m--){
            scanf("%d%d%d",&a,&b,&k);
            if(k<dis[a][b]) dis[a][b]=k;
            if(k<dis[b][a]) dis[b][a]=k;
        }
        /*
        //检查输入的dis数组
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++)
                printf("%d ",dis[i][j]);
            printf("\n");
        }
        */
        k=1;cost[k]=0;//入图
        //初始化cost数组
        for(i=2;i<=n;i++)
            cost[i]=dis[i][k];

        sum=0;//记录得到的最小生成树的权值
        for(i=1;i<=n;i++){
            //寻找已遍历的点到未遍历的点之间的最小权值并记录顶点
            min=intmax;
            for(j=1;j<=n;j++)
                if(cost[j]<min&&cost[j]>0){
                    min=cost[j];
                    k=j;
                }
            sum+=cost[k];
            cost[k]=0;//将找到的未遍历顶点标记为已遍历
            //更新cost数组
            for(j=1;j<=n;j++)
                if(dis[k][j]<cost[j])
                    cost[j]=dis[k][j];
        }
        printf("%d\n",sum);//打印得到的最小生成树的权值
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Mastering Python Networking English | 2017 | ISBN-10: 1784397008 | 446 pages | PDF + EPUB + MOBI (conv) | 9.76 Mb Key Features Build the skills to perform all networking tasks using Python with ease Use Python for Network Device Automation, DevOps, and Software Defined Networking Practical guide to networking with Python Book Description You will begin with a review of the TCP/IP Protocol Suite and to refresh the core elements of the Python language. Next you will start using Python to automate network devices and achieve all that you want from your network. You will then move to using Python for DevOps where you will be securing networks, monitoring networks, and building network services. In the last module, you will use Python for SDN, where you will use Python with OpenFlow, OpenStack , OpenDayLight, and NFV. Finally you will use everything you have learned so far in this book to construct a Python-based migration plan to go from legacy to a scalable SDN-based network. By the end of the book you will have all the skills required to perform complex network-related tasks with Python What you will learn Review of all the fundamentals of Python and TCP/IP suite Use Python to execute commands when the device does not support the API or programmatic interaction with the device Implement automation techniques by integrating Python with Cisco, Juniper, and and Arista EAPI Integrate Ansible using Python to control Cisco, Juniper, and Arista networks Achieve Network security with Python Build high-performing web services with Python Construct a Python-based migration plan from legacy to a scalable SDN-based network. Download from icerbox.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值