Networking-网络(Prim算法)

Networking 

POJ - 1287

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

您被分配设计广域中某些点之间的网络连接。您将获得该区域中的一组点,以及一组可能连接成对点的电缆的可能路线。对于两点之间的每条可能路线,您都会获得连接该路线上的点所需的电缆长度。请注意,两个给定点之间可能存在许多可能的路线。假设给定的可能路线连接(直接或间接)区域中的每两个点。
您的任务是为该区域设计网络,以便每两个点之间有一个连接(直接或间接)(即所有点都相互连接,但不一定通过直接电缆),并且总长度为使用的电缆最少。

输入

输入文件由许多数据集组成。每个数据集定义一个所需的网络。该集合的第一行包含两个整数:第一个定义给定点的数量 P,第二个定义点之间给定路线的数量 R。下面的 R 行定义了点之间的给定路线,每行给出三个整数:前两个数字标识点,第三个数字给出路线的长度。数字用空格分隔。仅给出一个数字 P=0 的数据集表示输入结束。数据集用空行分隔。
点的最大数量是 50。给定路线的最大长度是 100。可能的路线数量是无限的。节点用 1 到 P(含)之间的整数标识。两点 i 和 j 之间的路线可以表示为 ij 或 j i 。

输出

对于每个数据集,在单独的行上打印一个数字,给出用于整个设计网络的电缆总长度。

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

题意描述:给你几个点。和点间距,求遍布所有点间的距离最小值

解题思路:因为点间距可能有多个 所以我们需要写一个if 得到最短的值,把所有的值存入二维数组里面,然后利用prim求遍布所有点的最小值

#include<stdio.h>
#include<string.h>
int main()
{
	int e[110][110],dis[110],book[110];
	int i,j,n,m,u,v,min,t1,t2,t3;
	long long int sum;
	int inf=99999999;
	while(~scanf("%d",&n))
	{
		if(n==0)
		break;
		scanf("%d",&m);
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(i==j)
					e[i][j]=0;
				else
					e[i][j]=inf;
			}
		}
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&t1,&t2,&t3);
			if(e[t1][t2]>t3)
				e[t1][t2]=e[t2][t1]=t3;
		}
			for(i=1;i<=n;i++)
		{
			dis[i]=e[1][i];
			book[i]=0;	
		}	
		book[1]=1;
		sum=0;
		for(i=1;i<n;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&dis[j]<min)
				{
					min=dis[j];
					u=j;
				}
			}
			book[u]=1;
			sum+=dis[u];
			for(v=1;v<=n;v++)
			{
				if(book[v]==0&&dis[v]>e[u][v])
					dis[v]=e[u][v];
			}
		}
		printf("%d\n",sum);
	}	
	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值