HDU 1312 Red and Black(DFS)


Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19820    Accepted Submission(s): 12041


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1372  1240  1072  1181  1175 
 

Statistic |  Submit |  Discuss |  Note

经典DFS红与黑,没优化还以为会超时(我做的DFS就没不超时的。。),结果过了,有点激动

不需要结构体,不需要回退,每个黑块都可以走无数遍,这个问题就变得很简单了


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
//struct point{
//	int x,y,tile;
//};
//point<int>s;
char map[25][25];
int vis[25][25];
int maxv,n,m;
int dir[4][2]={1,0,-1,0,0,1,0,-1};
void dfs(int x,int y){
	int i,xx,yy;
	for(i=0;i<4;i++){
		xx=x+dir[i][0];
		yy=y+dir[i][1];
		if(xx>0&&xx<=n&&yy>0&&yy<=m&&map[xx][yy]!='#'&&!vis[xx][yy]){
			vis[xx][yy]=1;	
			maxv++;
			dfs(xx,yy);
			//vis[xx][yy]=0;
		}
	}
}
int main(){
	int i,j,sx,sy; 
	while(scanf("%d%d",&m,&n)&&m!=0&&n!=0){
		memset(vis,0,sizeof(vis));
		memset(map,0,sizeof(map));
		for(i=1;i<=n;i++){
			scanf("%s",map[i]+1);
		}
		for(i=1;i<=n;i++){
			for(j=1;j<=m;j++){
				if(map[i][j]=='@'){
					sx=i;sy=j; 
					vis[i][j]=1;
				}
			}
		}
		maxv=1; 
		dfs(sx,sy);
		printf("%d\n",maxv);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值