遥 控 器
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
3
-
描述
-
Dr.Kong有一台高级电视机,这台电视机可以接受100个频道(从0到99编号)。电视的配套遥控器有13个按钮:
1 2 3 ↑
4 5 6 ↓
7 8 9
— 0
当按"↑"键时,当前频道编号会增加1(如果当前为99频道,则会切换到0频道)。如果按"↓"键,当前频道编号会减小1(如果当前为0频道,则会切换到99频道)。当要切换到0~9频道时,可以直接在遥控器上按相应的键。当要切换到10~99频道时,可以先按"—"键,然后按2个与频道编号相对应的数字键(即先按与频道编号的十位数字相对应的键,然后按与个位数字相对应的键)。
由于遥控器长时间的使用和某些未知原因,遥控器上的某些键已经坏了,不能再起作用了。现在你的任务是,能否告诉Dr.Kong,如何用最少的按键次数来将频道从编号 X切换到编号 Y。-
输入
-
第一行: N表示有N组测试数据. (1<=N<=5)
对每组测试数据有5行,前4行包含遥控器上每个按键的信息。0表示对应的键坏了,1表示对应的键可以使用.第5行包含2个整数,分别是X 和 Y (0 <= X <= 99; 0 <= Y <= 99).
输出
- 对每组测试数据输出一行,即将频道从编号X切换到编号Y所需要的最小按键次数.如果不可能将频道从编号X 切换到编号Y,则输出-1. 样例输入
-
2
-
0 0 1 1
-
1 1 1 1
-
1 1 1
-
1 1
-
23 52
-
1 1 1 0
-
1 1 1 0
-
1 0 1
-
0 1
-
23 52
样例输出
-
4
-
-1
来源
- 第五届河南省程序设计大赛 上传者
- ACM_李如兵
-
第一行: N表示有N组测试数据. (1<=N<=5)
模拟题,我用BFS做的
跟玲珑杯 爱看电视的人有点类似,但是这题0到99成环,按两位频道数字时还要加上‘—’的一步
#include<stdio.h>
#include<string.h>
#include<queue>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
struct point{
int x,time;
};
int dir[2],key,vis[150],a[11],b[3],k;
int yu(int t){
int i,j,tt=t,num[3];
key=0;
if(t==0){
if(a[0]){
key=1;
return 1;
}
return 0;
}
i=0;
while(tt){
num[i]=tt%10;
tt/=10;i++;
}
if(i>1&&!k) return 0;
if(i>1) key++;
for(j=0;j<i;j++){
if(!a[num[j]])
return 0;
else key++;
}
return 1;
}
void bfs(point p,int len){
int i;
queue<point>que;
que.push(p);
point hd;
while(!que.empty()){
hd=que.front(); que.pop();
if(yu(hd.x)){
hd.time+=key;
if(hd.time>=len){
printf("%d\n",len);
return ;
}
printf("%d\n",hd.time);
return ;
}
if(hd.time>=len){
printf("%d\n",len);
return ;
}
for(i=0;i<2;i++){
int x=hd.x+dir[i];
if(x==-1) x=99;
if(x==100) x=0;
if(x==hd.x) continue;
if(!vis[x]){
point next;
next.x=x; next.time=hd.time+1;
vis[x]=1;
que.push(next);
}
}
}
printf("-1\n");
return ;
}
int main(){
int t,star,end,len;
scanf("%d",&t);
while(t--){
memset(a,0,sizeof(a));
memset(vis,0,sizeof(vis));
scanf("%d%d%d%d",&a[1],&a[2],&a[3],&b[0]);
scanf("%d%d%d%d",&a[4],&a[5],&a[6],&b[1]);
scanf("%d%d%d",&a[7],&a[8],&a[9]);
scanf("%d%d",&k,&a[0]);
scanf("%d%d",&star,&end);
if(star==end){
printf("0\n"); continue;
}
dir[0]=-1,dir[1]=1;
if(!b[0]) dir[0]=0;
if(!b[1]) dir[1]=0;
if(!b[0]&&!b[1]) len=100000;
else if(!b[0]&&end>star) len=100-end+star;
else if(!b[0]&&end<star) len=star-end;
else if(!b[1]&&end<star) len=100-star+end;
else if(!b[1]&&end>star) len=end-star;
else if(star<end) len=min(end-star,100-end+star);
else len=min(star-end,100-star+end);
vis[end]=1;
point p; p.x=end,p.time=0;
bfs(p,len);
}
return 0;
}