CentOS7安装Chrome浏览器 --和-- 遇到的问题汇总

简述

先说下我的运行环境,win10系统,安装的VMware11,在虚拟机中安装的CentOS7,具体参考(CentOS7 的安装)。安装过程中提示了三次错误,参考了网上的修改意见最终安装成功。

全程使用的主要命令如下:

ls
rpm
yum
sudo

一、下载安装包

下载地址:https://www.chrome64bit.com/index.php/google-chrome-64-bit-for-linux

进入页面下载rpm安装包


我将下载的rpm安装包,放在 /home/username/downsoft

进入这个目录,执行ls命令,查看文件无误,备用。

二、安装

执行命令,进入到软件存放的目录

 cd /home/username/soft

ls

现在我们就应该看到我们下载的文件了。

ok,我们接下来使用rpm来进行安装

rpm -ivh google-chrome-stable_current_x86_64.rpm

运行命令后,会出现类似如下警告:

第一种情况:


出现这个错误,是因为少了redhat-lsb这个依赖

安装readhat-lsb依赖:yum -y install  redhat-lsb

还有一种情况:

error: Failed dependencies:
    lsb >= 4.0 is needed by google-chrome-stable-50.0.2661.75-1.x86_64
    libXss.so.1()(64bit) is needed by google-chrome-stable-50.0.2661.75-1.x86_64

这时,除了需要安装redhat-lsb的依赖,还要安装libXss的依赖。我们继续安装依赖

yum install *lsb* -y
yum install libXss*  -y

当然安装了以上两个后,可能还有问题,你可以再 试试这几个命令

yum install pax*
yum install redhat-lsb*  -y
yum install libXss*  -y
ok,依赖我们应该安装好了,继续执行安装命令。

再来执行chrome安装包:rpm -ivh google-chrome-stable_current_x86_64.rpm 

rpm -ivh google-chrome-stable_current_x86_64.rpm

这时,可能会遇到如下图的情况:


我尝试了安装各种依赖,还是未果,始终出现这个提示。只能找度娘了。

参考了【Linux系统上安装MySQL 5.5prm,rpm依赖性检测失败解决】这篇中的解决问题方式。感谢分享

我调整了rpm安装的命令

sudo rpm -ivh google-chrome-stable_current_x86_64.rpm --nodeps
这次顺利执行了安装


这是我重复执行安装命令后的提示。初次安装提示内容会不同。


三、问题汇总

参数--nodeps

--nodeps就是安装时不检查依赖关系,比如你这个rpm需要A,但是你没装A,这样你的包就装不上,用了--nodeps你就能装上了。
--force就是强制安装,比如你装过这个rpm的版本1,如果你想装这个rpm的版本2,就需要用--force强制安装

安装命令rpm   

    参考 Linux RPM 命令参数使用详解

命令sudo

简单说,就是切换root权限执行一些操作

    参考 linux系统sudo命令详解



©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值