Gstreamer 编译安装

1. Download the latest version of gstreamer available at:
http://gstreamer.freedesktop.org/src/
The following are the files you need from version 1.6.0:
●  gstreamer-1.6.0.tar.xz
●  gst-plugins-base-1.6.0.tar.xz
●  gst-plugins-good-1.6.0.tar.xz
●  gst-plugins-bad-1.6.0.tar.xz

●  gst-plugins-ugly-1.6.0.tar.xz


2. Install needed packages with the following command:
sudo apt-get install build-essential dpkg-dev flex bison autotools-
dev automake liborc-dev autopoint libtool gtk-doc-tools
libgstreamer1.0-dev


3编译gstreamer-1.6.0

../configure --prefix=/home/ubuntu/gst_1.6.0/out
make
make install

4.

Set the PKG_CONFIG_PATH with the following command:
export PKG_CONFIG_PATH=/home/ubuntu/gst_1.6.0/out/lib/pkgconfig


5. Build gst-plugins-base-1.6.0 with the following commands

sudo apt-get install libxv-dev libasound2-dev libtheora-dev libogg-
dev libvorbis-dev
./configure --prefix=/home/ubuntu/gst_1.6.0/out
make
make install


6. Build gst-plugins-good-1.6.0 with the following commands:

sudo apt-get install libbz2-dev libv4l-dev libvpx-dev libjack-
jackd2-dev libsoup2.4-dev libpulse-dev
./configure --prefix=/home/ubuntu/gst_1.6.0/out
make
make install


7. Obtain and build gst-plugins-bad-1.6.0 with the following commands:

sudo apt-get install faad libfaad-dev libfaac-dev
./configure --prefix=/home/ubuntu/gst_1.6.0/out
make
make install


8.  Obtain and build gst-plugins-ugly-1.6.0 with the following commands:

sudo apt-get install libx264-dev libmad0-dev
./configure --prefix=/home/ubuntu/gst_1.6.0/out
make
make install


9.

Set the LD_LIBRARY_PATH environment variable with the following command:
export LD_LIBRARY_PATH=/home/ubuntu/gst_1.6.0/out/lib/


阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/jintaofu/article/details/51744706
个人分类: Gstreamer
想对作者说点什么? 我来说一句

Linux系统下安装gstreamer环境

2011年11月30日 24KB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭