hdoj 1004 表,模拟

Let the Balloon Rise
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 148560 Accepted Submission(s): 59013

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

简单模拟,思路正常如人都会的,就是统计出现过次数最多的颜色并打印而已(⊙﹏⊙),主要实现上花点时间,看代码吧

#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<list>
#include<iterator>
#include<stack>
#include <queue>
#include <cstdio>
//#include<algorithm>
using namespace std;
typedef  long long ll;
typedef unsigned long long ull;
#define e 2.718281828459
#define INF 0x7fffffff
#pragma warning(disable:4996)
#define sf scanf
#define pf printf
#define sf2d(x,y) scanf("%d %d",&(x),&(y))
#define sfd(x) scanf("%d",&x)
#define sff(p) scanf("%lf",&p)
#define pfd(x) printf("%d\n",x)
#define mset(x,b) memset((x),b,sizeof(x))
const double pi = acos(-1.0);
const long long mod = 1000000007LL;

struct node {
    int ans;
    string col;
    node  *next;
    node():ans(0),next(0){}
};



int main(void) {

    int n;
    while (sfd(n),n) {
        int ans = 0;
        string col;
        node* head = 0;
        node* tail = 0;

        for (int i = 0; i < n; i++) {
            node *p = new node;
            cin >> col;
            if (i == 0) {//第一个颜色
                head = p;
                tail = p;
                tail->next = 0;
                p->ans = 1;
                p->col = col;
                if (p->ans > ans)
                    ans = p->ans;
            }

            else {//后面的颜色,
                bool find = false;
                node* pp = head;
                while (pp&&!find) {
                    if (pp->col == col) {
                        find = true;
                        pp->ans++;
                        if (pp->ans > ans)
                            ans = pp->ans;
                    }
                    pp = pp->next;
                }

                if (pp == 0) {//若是一个新的颜色(到达链尾,未找到)需要增加长度
                    pp = new node;
                    tail->next = pp;
                    tail = pp;
                    tail->next = 0;
                    tail->ans = 1;
                    tail->col = col;
                    if (pp->ans > ans)
                        ans = pp->ans;

                }

            }
        }


        node* pm = head;
        node* ne;
        while (pm) {
            if (pm->ans == ans) {
                cout << pm->col << endl;
                break;
            }
            pm = pm->next;
        }

        pm = head;
        while (pm) {
            ne = pm->next;
            delete pm;
            pm = ne;
        }

    }



    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值