【pta甲级】1006 Sign In and Sign Out (25 分)

1006 Sign In and Sign Out (25 分)
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

大概就是排序求极值,很简单的,格式化输入就用scanf
我自己用了结构体,和排序,算是练习一下这两个的使用,柳神的代码更简洁。

#include<bits/stdc++.h>
using namespace std;
struct yonghu{
    string id;
    long long in;
    long long out;
};
bool cmp(yonghu a,yonghu b){
    return a.in<b.in;
}
bool cmp1(yonghu a,yonghu b){
    return a.out>b.out;
}
int main()
{
   int m;
   cin>>m;
    yonghu hu[m+5];
   int s,f,mi;
   for(int i=0;i<m;i++){
       cin>>hu[i].id;
       scanf("%d:%d:%d",&s,&f,&mi);
       hu[i].in=s*3600+f*60+mi;
    scanf("%d:%d:%d",&s,&f,&mi);
       hu[i].out=s*3600+f*60+mi;
   }
    sort(hu,hu+m,cmp);

    cout<<hu[0].id<<' ';
    sort(hu,hu+m,cmp1);

    cout<<hu[0].id;


    return 0;
}



附上柳神代码作对比
转自:https://www.liuchuo.net/archives/2017
#include <iostream>
#include <climits>
using namespace std;
int main() {
    int n, minn = INT_MAX, maxn = INT_MIN;
    scanf("%d", &n);
    string unlocked, locked;
    for(int i = 0; i < n; i++) {
        string t;
        cin >> t;
        int h1, m1, s1, h2, m2, s2;
        scanf("%d:%d:%d %d:%d:%d", &h1, &m1, &s1, &h2, &m2, &s2);
        int tempIn = h1 * 3600 + m1 * 60 + s1;
        int tempOut = h2 * 3600 + m2 * 60 + s2;
        if (tempIn < minn) {
            minn = tempIn;
            unlocked = t;
        }
        if (tempOut > maxn) {
            maxn = tempOut;
            locked = t;
        }
    }
    cout << unlocked << " " << locked;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值