【PAT甲级】 1006 Sign In and Sign Out

【PAT甲级】 1006 Sign In and Sign Out

原题

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input 1:

    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40

Sample Output 1:

    SC3021234 CS301133

思路

题目要求

给定所有记录的ID和进出时间,输出最先进入的人和最后出去的人

题目分析

  1. 输出最后无空格;
  2. 输出为一行;
  3. 题目给定进入时间小于出去时间,且同时不会有两个人;
  4. 直接找出进入时间的最小值和出去时间的最大值;

易错点

  1. 判断的时候string可以直接比较;
  2. 在map中如果出现类似于复数等形式,要先重载小于运算符(因为map默认按小于排序);
  3. 取end值以后要再减一;
  4. 如果题目不是时分秒,即最大的值不在最前面则不能直接比较;

参考代码如下

#include <iostream>
#include <map>
using namespace std;
int main(){
	map<string,string> s1;
	map<string,string> s2;
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		string a,b,c;
		cin>>a>>b>>c;
		s1[b]=a;//s1表示进入时间
		s2[c]=a;//s2表示出去时间
		// 这里也可以用insert
		// s1.insert(pair<string, string>(b, a));
	}
	auto ss = s2.end();
	ss--;
	// 直接输出(s2.end()--)->second是不行的,具体原因我也不清楚
	cout<<s1.begin()->second<<" "<<ss->second;
}

  • 网上的参考代码很多;
  • 以上仅是用来记录我个人的想法和答题方式;
  • 仅为入门选手,如有错误或者更好的方法欢迎指正与探讨;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值