Sum It Up HOJ1258

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8382    Accepted Submission(s): 4406

Problem Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input

4 6 4 3 2 2 1 1

5 3 2 1 1

400 12 50 50 50 50 50 50 25 25 25 25 25 25

0 0

Sample Output

Sums of 4:

4 3+1 2+2 2+1+1

Sums of 5: NONE

Sums of 400:

50+50+50+50+50+50+25+25+25+25

50+50+50+50+50+25+25+25+25+25+25

 

若有数组为{a,b,c,d,e,f,g} 则从左向右的顺序另若干个数加起来,使得和的结果为一个给定的sum。则可利用递归的思想,将数组分为两个部分,其中程序刚开始运行时,第一部分为{},第二部分为{a,b,c,d,e,f,g}。然后利用for循环,另第二部分中的某个数和0相加,结果作为和。此时之前的第一部分和第二部分都被更新。

#include<cstdio>
#include<algorithm>
using namespace std;
int SUM,number,list[12];
int vis[12];
int a[13];
bool Flag;
bool comp(const int &a,const int &b) {
	return a>b;
}
void init() {
	Flag=false;
}
void dfs(int sum,int start,int cur) { //be_cur  begin_cursor    ac_cur  active_cursor
	if(sum>SUM) return;
	if(sum==SUM) {
		Flag=true;
		printf("%d",a[0]);
		for(int i=1; i<cur; i++) {
			printf("+%d",a[i]);
		}
		printf("\n");
		return;
	}
	for(int i=start; i<number; i++) {//从第二部分进行选择某一个元素
		a[cur]=list[i];
		dfs(sum+list[i],i+1,cur+1);//一旦进入内部,则第一部分被更新为sum+list[i],第二部分的开始的下标为i+1
		while(i+1<number&&list[i]==list[i+1])//搜索完毕后,若下一个搜索的数仍与当前相同,则跳过直至不相同
			i++;
	}
}
int main() {
	freopen("in.txt","r",stdin);
	while(scanf("%d%d",&SUM,&number) && SUM!=0 && number!=0) {
		for(int i=0; i<number; i++) scanf("%d",&list[i]);
		sort(list,list+number,comp);
		printf("Sums of %d:\n",SUM);
		init();
		dfs(0,0,0);
		if(Flag==0) {
			printf("NONE\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值