中国剩余定理

中国剩余定理详解见:https://www.cnblogs.com/linyujun/p/5199415.html

我是没怎麽理解这个定理,此题套用模板

一个正整数K,给出K Mod 一些质数的结果,求符合条件的最小的K。例如,K % 2 = 1, K % 3 = 2, K % 5 = 3。符合条件的最小的K = 23。

Input

第1行:1个数N表示后面输入的质数及模的数量。(2 <= N <= 10)
第2 - N + 1行,每行2个数P和M,中间用空格分隔,P是质数,M是K % P的结果。(2 <= P <= 100, 0 <= K < P)

Output

输出符合条件的最小的K。数据中所有K均小于10^9。

Sample Input

3
2 1
3 2
5 3

Sample Output

23

代码:

#include<algorithm>
using namespace std;
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<stdio.h>
typedef long long int LL;
void ex_gcd(LL a,LL b,LL &x,LL &y)
{
    if(!b)
    {
        x=1;
        y=0;
    }
    else
    {
        ex_gcd(b,a%b,y,x);
        y-=x*(a/b);
    }
}
LL inv(LL m,LL n)
{
    LL x,y;
    ex_gcd(m,n,x,y);
    return x%n+n;
}
LL CRT(LL *n,LL *m,LL t)
{
    LL s=0,k=1,i;
    for(i=0;i<t;i++)
        k*=m[i];
    for(i=0;i<t;i++)
    {
        LL temp=k/m[i];
        s=(s+temp*inv(temp,m[i])*n[i])%k;
    }
    return (s+k)%k;
}
int main()
{
    LL m[20],n[20],k,i,s=0;
    while(~scanf("%lld",&k))
    {
        for(i=0;i<k;i++)
            scanf("%lld%lld",&m[i],&n[i]);
        s=CRT(n,m,k);
        printf("%lld\n",s);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值