SDUT oj面向对象2-2 Time类的定义

2-2 Time类的定义

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

通过本题目的练习可以掌握类与对象的定义;

设计一个时间类Time,私有数据成员有hour(时)、minute(分)、second(秒);

公有成员函数有:setHour(int)设置数据成员hour的值(采用12小时制),非法的输入默认为12;setMinue(int)设置数据成员minute的值,非法输入默认为0;setSecond(int)设置数据成员second的值,非法输入默认为0;setTime(int,int,int)设置时、分、秒三个数据成员的值; showTime()显示时间对象的值。

在主函数main()中调用相应成员函数,使得时间对象的值能从键盘接收,并正确显示。

提示:时、分、秒均按2位数值形式显示 。

Input

输入3个整数,用一个空格间隔

Output

输出 时、分、秒的值,中间用“:”间隔

Example Input

10 11 12

Example Output

10:11:12

Author

 黄晶晶

c++面向对象类的入门操作

#include <iostream>

using namespace std;

class Time
{
private:
  int hour;
  int minute;
  int second;
public:
  int Sethour(int a)
  {
    if(a<0||a>12)
      a=12;
    else
      a=a;
    return a;
  }
  int Setminte(int b)
  {
    if(b<0||b>60)
      b=0;
    else
      b=b;
    return b;
  }
  int Setsecond(int c)
  {
    if (c<0||c>60)
      c=0;
    else
      c=c;
    return c;
  }
  void setTime(int a, int b, int c)
  {
    hour=a;
    minute=b;
    second=c;
  }
  void  ShowTime()
  {
    if(hour>=10)
      cout<<hour ;
    else
      cout<<"0"<<hour;
    cout<<":";
    if(minute>=10)
      cout<<minute;
    else
      cout<<"0"<<minute;
    cout<<":";
    if(second>=10)
      cout<<second<<endl;
    else
      cout<<"0"<<second<<endl;
  }
};
int main()
{
  Time T;
  int a,b,c;
  cin>>a>>b>>c;
  a=T.Sethour(a);
  b=T.Setminte(b);
  c=T.Setsecond(c);
  T.setTime(a,b,c);
  T.ShowTime();
  return 0;
}

 

 

 

  • 1
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值