POJ 2253Frogger(最短路floyd)

Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39182 Accepted: 12608

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:一只叫Freddy的青蛙蹲坐在湖中的一块石头上。突然他发现一只叫Fiona的青蛙在湖中的另一块石头上。Freddy想要跟Fiona约会,但由于湖水太脏,他不想游泳过去而是跳过去找Fiona。
很不幸,Fiona所在的石头距离他有点远,甚至超出了他的跳跃能力。然而Freddy注意到湖中还有一些其他的石头。这些石头也许会将这个很长的跳跃距离化成若干个短的跳跃距离。

题解:用到floyd算法;

第二个例子:第一个点到第二个点的距离为2,第一个和第二个点的距离是根2,第二个点和第三个点的距离是根2,所以青蛙为了避免跳最大距离,就先跳到三点,然后跳到2点,一共跳了两段,两段中最小的一段是根2。

#include <iostream>
#include <iomanip>
#include <math.h>
#include <string.h>
using namespace std;

struct node
{
  int x, y;
} step[205];

double Map[205][205];

int main()
{
  int n, i, j, k;
  int cesa = 0;
  while(cin>>n)
    {
      cesa ++;
      if(n == 0)
        return 0;
      memset(Map, 0, sizeof(Map));
      for(i = 1; i <= n; i++)
        {
          cin>>step[i].x>>step[i].y;
        }
      //双向的,找到两点之间的最距离,即两点间的权值;
      for(i = 1; i <= n - 1; i++)
        for(j = i + 1; j <= n; j++)
          {
            int xi = step[i].x - step[j].x;
            int yi = step[i].y - step[j].y;
            Map[i][j] = Map[j][i] = sqrt(xi * xi + yi * yi);
          }
      //用floyd算法的变形
      for(i = 1; i <= n; i++)
        for(j = 1; j <= n - 1; j++)
          for(k = j + 1; k <= n; k++)
            {
              //保证两点到第三点的距离都小于两点的原有距离
              if(Map[j][k] > Map[j][i] && Map[j][k] > Map[i][k])
                {
                  //选取大的一比为两点的最终距离
                  if(Map[j][i] > Map[i][k])
                    {
                      Map[j][k] = Map[k][j] = Map[j][i];
                    }
                  else
                    {
                      Map[j][k] = Map[k][j] = Map[k][i];
                    }
                }
            }
      cout<<"Scenario #"<<cesa<<endl;
      cout<<"Frog Distance = ";
      cout<<fixed<<setprecision(3)<<Map[1][2]<<endl<<endl;
    }

  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值