Frogger(最短路)

Frogger
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 42402
Accepted: 13535
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 


You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4


3
17 4
19 4
18 5


0
Sample Output
Scenario #1
Frog Distance = 5.000


Scenario #2
Frog Distance = 1.414
Source

Ulm Local 1997


*********************************************************

这道题的思路其实就是求最短路,可以用迪杰斯特拉来做,这道题这的是坑死我了,就是因为double,现在长知识了微笑
---------------------------------------------------------
G++:
printf()中double类型的输出为%f;
定义一个函数中:
double cmp(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
函数cmp返回值就是double类型
----------------------------------------------------------
C++:
printf()中double类型的输出为%lf;
定义一个函数中:
double cmp(node a,node b)
{
    return sqrt(double(a.x-b.x)*(a.x-b.x)+double(a.y-b.y)*(a.y-b.y));
}
函数cmp中,必须在return中加强制性转换为double类型,返回值才是double类型


G++:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define maxn 310
#define inf 0x3fffffff
#define max(a,b) (a>b?a:b)
using namespace std;
typedef struct
{
    int x;
    int y;
}node;
node stu[maxn];
double d[maxn];
int n;
double cmp(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
void dijkstra()
{
    int i,j,vis[maxn],v=1;
    double min;
    for(i=1;i<=n;i++)
    {
        d[i]=inf;
        vis[i]=0;
    }
    d[1]=0;
    for(i=1;i<=n;i++)
    {
        min=inf;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&d[j]<min)
            {
                min=d[j];
                v=j;
            }
        }
        vis[v]=1;
        if(v==2)
            break;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&d[j]>max(d[v],cmp(stu[v],stu[j])))
                d[j]=max(d[v],cmp(stu[v],stu[j]));
        }
    }
}

int main()
{
    int i,cnt=1;
    while(scanf("%d",&n)&&n)
    {
        for(i=1;i<=n;i++)
        scanf("%d%d",&stu[i].x,&stu[i].y);
        dijkstra();
        printf("Scenario #%d\nFrog Distance = %.3f\n\n",cnt++,d[2]);
    }
    return 0;
}



C++:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define maxn 310
#define inf 0x3fffffff
#define max(a,b) (a>b?a:b)
using namespace std;
typedef struct
{
    int x;
    int y;
}node;
node stu[maxn];
double d[maxn];
int n;
double cmp(node a,node b)
{
    return sqrt(double(a.x-b.x)*(a.x-b.x)+double(a.y-b.y)*(a.y-b.y));
}
void dijkstra()
{
    int i,j,vis[maxn],v=1;
    double min;
    for(i=1;i<=n;i++)
    {
        d[i]=inf;
        vis[i]=0;
    }
    d[1]=0;
    for(i=1;i<=n;i++)
    {
        min=inf;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&d[j]<min)
            {
                min=d[j];
                v=j;
            }
        }
        vis[v]=1;
        if(v==2)
            break;
        for(j=1;j<=n;j++)
        {
            if(!vis[j]&&d[j]>max(d[v],cmp(stu[v],stu[j])))
                d[j]=max(d[v],cmp(stu[v],stu[j]));
        }
    }
}

int main()
{
    int i,cnt=1;
    while(scanf("%d",&n)&&n)
    {
        for(i=1;i<=n;i++)
        scanf("%d%d",&stu[i].x,&stu[i].y);
        dijkstra();
        printf("Scenario #%d\nFrog Distance = %.3lf\n\n",cnt++,d[2]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值