POJ 2635The Embarrassed Cryptographer(数论-素数筛)

The Embarrassed Cryptographer

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14461 Accepted: 3954

Description

The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input

The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output

For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input

143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output

GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

Source

题意:给定一个大数, 大的超过long long,只能用字符串来存。再给一个m,int型。因为给定每个数都可以分解成两个质因数的积,问这两个质数的大小是否小于m,如果小于m就输出BAD+质数,否则输出GOOD。

题解:大数的分解,可以有10进制转化为1000进制,然后在连接这些时,每次通过对1-m内的质数取余来链接,同时用到线性素数筛来筛选质数。

#include<iostream>  
#include<stdio.h>  
#include<math.h>  
#include<string.h> 

using namespace std;  

#define Max 1100000  

int isp[Max]; 

void isprim()  //打表
{  
    int i,j;  
    isp[0]=isp[1]=0;  //0,1为素数
    isp[2]=1; //2为素数
    for(i=3;i<Max;i++)  //大于2的偶数都不是素数
        isp[i]=i%2;  
    int ns;  
    ns=(int)sqrt(Max*1.0);  
    for(i = 3;i <= ns;i++)  
    {  
        if(isp[i])  
        {  
            for(j = i * i;j < Max;j = j + 2 * i)  
                isp[j]=0;  
        }  
    }  
}  
int main()  
{  
    int len,n,i,j,k,ks;  
    int num,nums;  
    char str[1000];  
    isprim();  
    while(scanf("%s%d",str,&n)&&(!(str[0]=='0'&&n==0)))  
    {  
        len=strlen(str);  
        for(k=2;k<n;k++)  
        {  
            if(isp[k]==0)  
            { 
                continue;  
            } 
            num=0;  
             for(i=0;i<len;i+=3)  //分解字符串
            {  
                 nums=0;  
                ks=1;  
                for(j=i;j<i+3&&j<len;j++)  //将相邻的个字符转换成一个千位数。
                {  
                    ks=ks*10;  
                    nums=nums*10+(str[j]-'0');                   
                 }  
                num=num*ks+nums;  
                num=num%k;  //保证了每次num都是一个小于k万的一个int型整数
            }  
            if(num==0)  
            {                      
                printf("BAD %d\n",k);  
                break;  
            }  
        }  
        if(k==n)
            printf("GOOD\n");  //找完了没找到
     }  
     return 0;  
}  



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值