ISDN DDR

【实验设备】
  
  带S/T接口或U接口的Cisco路由器三部,带E1 controller的路由器一台,带超级终端的PC机三台,Atlas550一台,相应的连接线若干。
  
  【实验内容】
  
  一、 配置ISDN BRI接口
  
  1.实验拓扑图如下:
  


  上图中,如果采用的是net3信令,则不用配置SPID。
  
  2.BRI接口配置
  
  (1)配置任务如下:
  
  在全局配置模式下配置交换机类型
  
  配置BRI接口的IP/mask,配置封装方式为PPP,并配置CHAP认证方式
  
  配置DDR
  
  如果有需要相应的路由信息的话,一般情况下为了节省动态更新带来的额外开销,常常配置静态或默认路由。
  
  配置可选参数,如dialer idle-timeout, dialer fast-idle timeout等。
  
  (2)具体配置如下:
  
  下面以SanJose1的为例,Capetown的与SanJose1的类似。
  
  SanJose1(config)#username Capetown password cisco //为CHAP配置用户名和密码
  SanJose1(config)#isdn switch-type basic-net3 //配置接入方交换机类型
  SanJose1(config)#interface bri0/0
  SanJose1(config-if)#ip address 192.168.16.1 255.255.255.0
  SanJose1(config-if)#encapsulation ppp
  SanJose1(config-if)#ppp authentication chap
  SanJose1(config-if)#dialer map ip 192.168.16.3 name Capetown broadcast 5552000
  //DDR配置,其中5552000为对端号码
  SanJose1(config-if)#dialer-group 1    //绑定触发性列表
  SanJose1(config)#dialer-list 1 protocol ip permit  //定义触发性列表
  SanJose1(config)#ip route 192.168.216.0 255.255.255.0 192.168.16.3
  SanJose1(config-if)#dialer idle-timeout 60    //配置空闲时间值

 

 

例子中沿用PPP配置的拓扑图.
    另:P1R2的bri1/0的IP:172.16.10.1 掩码:255.255.255.0
         P2R2的bri1/0的IP:172.16.10.2 掩码:255.255.255.0

1.使用dialer map
    这部分DDR的配置中,BRI连接速率和拨号空闲定时器等参数都是直接配置在物理接口上的.所有使用该接口的连接都可以使用这些参数.

p1r2配置:
p1r2(config)#config t
p1r2(config)#username p2r2 password cisco  //为CHAP配置用户名和密码
p1r2(config)#isdn switch-type basic-ni  //配置接入方交换机类型
p1r2(config)#interface bri1/0
p1r2(config-if)#ip address 172.16.10.1 255.255.255.0
p1r2(config-if)#isdn spid1 321555200100
p1r2(config-if)#encapsulation ppp
p1r2(config-if)#ppp authentication chap
p1r2(config-if)#dialer map ip 172.16.10.2 name p2r2 broadcast 5552002
                                    //DDR配置,其中5552000为对端号码
p1r2(config-if)#dialer-group 1       //绑定触发性列表
p1r2(config-if)#shut
p1r2(config-if)#no shut
p1r2(config-if)#exit
p1r2(config)#dialer-list 1 protocol ip list 101    //定义触发性列表
p1r2(config)#access-list 101 permit icmp any any

p2r2配置:
p2r2(config)#config t
p2r2(config)#username p1r2 password cisco  //为CHAP配置用户名和密码
p2r2(config)#isdn switch-type basic-ni  //配置接入方交换机类型
p2r2(config)#interface bri1/0
p2r2(config-if)#ip address 172.16.10.2 255.255.255.0
p1r2(config-if)#isdn spid1 321555200200
p2r2(config-if)#encapsulation ppp
p2r2(config-if)#ppp authentication chap
p2r2(config-if)#dialer map ip 172.16.10.1 name p1r2 broadcast 5552001
                                    //DDR配置,其中5552000为对端号码
p2r2(config-if)#dialer-group 1       //绑定触发性列表
p2r2(config-if)#shut
p2r2(config-if)#no shut
p2r2(config-if)#exit
p2r2(config)#dialer-list 1 protocol ip list 101    //定义触发性列表
p2r2(config)#access-list 101 permit icmp any any

    在做这个练习时候,总是配错一个地方,就是在第二个路由器上的BRI1/0接口上配置isdn spid时,后面也是1.^_^

2.dialer profile
    dialer profile用于将已有DDR配置的许多配置参数从物理接口中分离出来.配置了逻辑拨号接口后,就无须配置物理接口.当一个呼叫需要使用逻辑拨号接口时,它将绑定到拨号池中的一个物理接口上.
    在dialer profile中,参数配置在逻辑拨号接口上,并且只有当在一个连接使用那个逻辑拨号接口时才能使用这些参数.当连接建立时,这些参数被绑定并应用到物理接口上.依靠dialer profile,物理接口只须保持最小配置,复杂配置转移到逻辑拨号接口上.
    在dialer profile中,逻辑拨号接口处于待机模式,而物理接口可以自由地用于其他服务.
    interface bri0
      encapsulation ppp
      ppp authentication chap
      dialer pool-member 1
    !
    interface dialer0
      ip address 172.16.10.1 255.255.255.0
      encapsulation ppp
      ppp authentication chap
      dialer remote-name p2r2
      dialer string 30001
      dialer pool 1
      dialer group 1
    !
    dialer-list 1 protocol ip list 101
    access-list 101 permit icmp any any


 

阅读更多
换一批

没有更多推荐了,返回首页