Description
huyichen世子事件后,xuzhenyi成了皇上特聘的御前一品侍卫。 皇宫以午门为起点,直到后宫嫔妃们的寝宫,呈一棵树的形状;某些宫殿间可以互相望见。大内保卫森严,三步一岗,五步一哨,每个宫殿都要有人全天候看守,在不同的宫殿安排看守所需的费用不同。 可是xuzhenyi手上的经费不足,无论如何也没法在每个宫殿都安置留守侍卫。 帮助xuzhenyi布置侍卫,在看守全部宫殿的前提下,使得花费的经费最少。
Input
输入文件中数据表示一棵树,描述如下: 第1行 n,表示树中结点的数目。 第2行至第n+1行,每行描述每个宫殿结点信息,依次为:该宫殿结点标号i(0< i< =n),在该宫殿安置侍卫所需的经费k,该边的儿子数m,接下来m个数,分别是这个节点的m个儿子的标号r1,r2,...,rm。 对于一个n(0 < n < = 1500)个结点的树,结点标号在1到n之间,且标号不重复。
Output
输出文件仅包含一个数,为所求的最少的经费。
Sample Input
61 30 3 2 3 42 16 2 5 63 5 04 4 05 11 06 5 0
Sample Output
25
HINT
#include<stdio.h>
int n,idx,to[3001],pre[3001],B,last[1501],a[1501],c[1501],d[1501],dp[1501][3];
int min(int a,int b)
{
if(a<b)
return a;
return b;
}
void dfs(int p,int from)
{
dp[p][1]=c[p];
int flag=0x7f7f7f7f;
for(int i=last[p];i;i=pre[i])
{
if(to[i]!=from)
{
dfs(to[i],p);
dp[p][0]+=min(dp[to[i]][1],dp[to[i]][0]);
dp[p][1]+=min(dp[to[i]][1],min(dp[to[i]][2],dp[to[i]][0]));
dp[p][2]+=min(dp[to[i]][0],dp[to[i]][1]);
if(dp[to[i]][1]<=dp[to[i]][0])
flag=0;
if(flag&&dp[to[i]][1]-dp[to[i]][0]<flag)
flag=dp[to[i]][1]-dp[to[i]][0];
}
}
dp[p][0]+=flag;
}
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
scanf("%d%d",&c[a[i]],&d[i]);
while(d[i]--)
{
scanf("%d",&B);
++idx;
pre[idx]=last[a[i]];
to[idx]=B;
last[a[i]]=idx;
++idx;
pre[idx]=last[B];
to[idx]=a[i];
last[B]=idx;
}
}
dfs(1,0);
printf("%d",min(dp[1][0],dp[1][1]));
}