USACO 2012 Mar Bronze 1.Times 17

Description

Problem 1: Times17 [Brian Dean, 2012]

After realizing that there is much money to be made in software
development, Farmer John has launched a small side business writing short
programs for clients in the local farming industry.  

Farmer John's first programming task seems quite simple to him -- almost
too simple: his client wants him to write a program that takes a number N
as input, and prints 17 times N as output.  Farmer John has just finished
writing this simple program when the client calls him up in a panic and
informs him that the input and output both must be expressed as binary
numbers, and that these might be quite large.

Please help Farmer John complete his programming task.  Given an input
number N, written in binary with at most 1000 digits, please write out the
binary representation of 17 times N.

Input

* Line 1: The binary representation of N (at most 1000 digits).

Output

* Line 1: The binary representation of N times 17.

Sample Input

10110111

Sample Output

110000100111

HINT

OUTPUT DETAILS:

The binary number 10110111 is equal to 183 in decimal form.
183 x 17 = 3111 is 110000100111 in binary format.


水题


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int num[10005],m,sum[100005],h,idx;
char a[10005],b[10005];
int main()
{
     scanf ( "%s" ,a);
     h= strlen (a);
     reverse(a,a+h);
     for ( int i=0;i<h;i++)
     sum[i]=a[i]- '0' ;
     reverse(a,a+h);
     m=h;
     a[m]= '0' ;
     a[m+1]= '0' ;
     a[m+2]= '0' ;
     a[m+3]= '0' ;
     a[m+4]= '\0' ;
     reverse(a,a+ strlen (a));
     m= strlen (a);
     for ( int i=0;i<m;i++)
     num[i]=a[i]- '0' ;
     for ( int i=0;i<h+m;i++)
     {
        sum[i]+=num[i];
        if (sum[i]>=2)
        {
             sum[i]-=2;
             sum[i+1]++;
         }
     }
     for ( int i=h+m;i>=0;i--)
     if (sum[i]!=0)
     {
         idx=i;
         break ;
     }
     h=idx+1;
     for ( int i=h-1;i>=0;i--)
     printf ( "%d" ,sum[i]);
}

AC 顶一个
  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值