hdu—1081

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12418    Accepted Submission(s): 5959


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 
9 2 -6 2 -4 1 -4 1 
-18 0 -2
 

Sample Output
  
  
15
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1024  1025  1080  1078  1074 

【分析】
最大矩阵和...数据挺小的所以直接预处理一下(1,1)到(i,j)的区间和...然后直接n^4去模拟任意两点之前的区间和就好了...当然区间和不是直接求的
f[i][j]表示从(1,1)到(i,j)这个区间的区间和
那么对于(i,j)和(x,y)两点之间的区间和就是 f[x][y]-f[x][j-1]-f[i-1][y]+f[i-1][j-1]减去两段边上的加上那一个被重复减去的区间...这个画个图就知道了

目标是白色区间和,f[x][y]减去红色和蓝色区间和之后再把被减去两次的重复区域和补回就可以了~
【代码】
#include <bits/stdc++.h>
using namespace std;
int f[110][110];
int a[110][110];
int main()
{
	int n;
	while (~scanf("%d",&n))
	{
		memset(f,0,sizeof(f));
		int ans=-2100000000;
		for (int i=1;i<=n;i++)
			for (int j=1;j<=n;j++)
			{
				scanf("%d",&a[i][j]);
				ans=max(ans,a[i][j]);
				f[i][j]=f[i-1][j]+f[i][j-1]-f[i-1][j-1]+a[i][j];
				ans=max(ans,f[i][j]);
			}
		for (int i=1;i<=n;i++)
			for (int j=1;j<=n;j++)
				for (int x=i;x<=n;x++)
					for (int y=j+(x==i?1:0);y<=n;y++)
					{
						int t=f[x][y]-f[x][j-1]-f[i-1][y]+f[i-1][j-1];
						ans=max(ans,t);
					}
		printf("%d\n",ans);
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值