POJ ACM习题【No.3673】

Cow Multiplication
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4282 Accepted: 2847

Description

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A *B is equal to the sum of all possible pairwise products between the digits of A and B . For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.

Input

* Line 1: Two space-separated integers: A and B .

Output

* Line 1: A single line that is the A*B in Bessie's style of multiplication.

Sample Input

123 45

Sample Output

54

 

此种运算的思路即为ABC*XY = (A+B+C)*(X+Y),分开运算即可

 

import java.util.*;

public class Main {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		String[] str = null;
		String a = null;
		String b = null;

		int numa = 0;
		int numb = 0;
		
		while (cin.hasNext())
		{
			numa = 0;
			numb = 0;
			
			str = cin.nextLine().split(" ");
			a = str[0];
			b = str[1];
			
			for(int i = 0; i < a.length(); i++)
				numa = numa + Integer.valueOf(""+a.charAt(i));
			
			for(int j = 0; j < b.length(); j++)
				numb = numb + Integer.valueOf(""+b.charAt(j));
			
			System.out.println(numa * numb);
			
		}
	}

}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值