http://poj.org/problem?id=3673
Cow Multiplication
Description
Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie's style of multiplication.
Input
* Line 1: Two space-separated integers: A and B.
Output
* Line 1: A single line that is the A*B in Bessie's style of multiplication.
Sample Input
123 45
Sample Output
54
#include<iostream>
#include<string>
using namespace std;
int main()
{
string a,b;
while(cin>>a>>b)
{
int sum(0);
for(int i=0;i<a.size();i++)
for(int j=0;j<b.size();j++)
sum+=(a[i]-'0')*(b[j]-'0');
cout<<sum<<endl;
}
}