2016SDAU课程练习一1005 Problem F

Problem F
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 100   Accepted Submission(s) : 36
Problem Description
"Yakexi, this is the best age!" Dong MW works hard and get high pay, he has many 1 Jiao and 5 Jiao banknotes(纸币), some day he went to a bank and changes part of his money into 1 Yuan, 5 Yuan, 10 Yuan.(1 Yuan = 10 Jiao)
"Thanks to the best age, I can buy many things!" Now Dong MW has a book to buy, it costs P Jiao. He wonders how many banknotes at least,and how many banknotes at most he can use to buy this nice book. Dong MW is a bit strange, he doesn't like to get the change, that is, he will give the bookseller exactly P Jiao.
 

Input
T(T<=100) in the first line, indicating the case number. T lines with 6 integers each: P a1 a5 a10 a50 a100 ai means number of i-Jiao banknotes. All integers are smaller than 1000000.
 

Output
Two integers A,B for each case, A is the fewest number of banknotes to buy the book exactly, and B is the largest number to buy exactly.If Dong MW can't buy the book with no change, output "-1 -1".
 

Sample Input
  
  
3 33 6 6 6 6 6 10 10 10 10 10 10 11 0 1 20 20 20
 

Sample Output
  
  
6 9 1 10 -1 -1
 又是数硬币,要求得出最大和最小硬币数,很相似之前做的第二套练习题的数硬币的题,只不过这道题要求得出最大硬币数,而这也正是本题的最大难点。
关键是转换,把最多转化为钱最多硬币最少,这一步好难好难的。。。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<algorithm>
using namespace std;
int min(int r,int b[],int c[],int a[]){
    for(int i=5;i>0;i--){
        if(r/b[i]<a[i]){
            c[i]=r/b[i];
            r=r-b[i]*c[i];
        }
        else{
            c[i]=a[i];
            r=r-c[i]*b[i];
        }
    }
    return r;
}
int max(int k,int e[],int b[],int a[]){
    for(int i=5;i>0;i--){
        if(k/b[i]<a[i]){
            e[i]=k/b[i];
            k-=b[i]*e[i];
        }
        else{
            e[i]=a[i];
            k=k-e[i]*b[i];
        }
    }
    return k;
}
int main(){
    int a[7],c[7],e[7],b[6]={0,1,5,10,50,100};
    int p,r,sum,k;
    int t;
    cin>>t;
    while(t--){
        sum=0;
        cin>>p;
        r=p;
        for(int i=1;i<=5;i++){
            cin>>a[i];
            sum+=b[i]*a[i];
            r=min(r,b,c,a);
            if(r!=0){
                cout<<"-1 -1"<<endl;
                continue;
            }
            else{
                k=sum-p;
                k=max(k,e,b,a);
                if(k==0){
                    printf("%d %d\n",c[1]+c[2]+c[3]+c[4]+c[5],(a[1]+a[2]+a[3]+a[4]+a[5]-(e[1]+e[2]+e[3]+e[4]+e[5])));
                }
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值