SDAU课程练习2 1005

Turn the corner

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 15   Accepted Submission(s) : 7
Problem Description
Mr. West bought a new car! So he is travelling around the city.<br><br>One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.<br><br>Can Mr. West go across the corner?<br><img src=../../../data/images/2438-1.jpg><br>
 

Input
Every line has four real numbers, x, y, l and w.<br>Proceed to the end of file.<br>
 

Output
If he can go across the corner, print "yes". Print "no" otherwise.<br>
 

Sample Input
  
  
10 6 13.5 4<br>10 6 14.5 4<br>
 

Sample Output

yes<br>no<br>

题目大意:

车拐弯,给出车长车宽,街道长和宽。问是否可以转过去。

思路:

列出公式,函数是一个先增后减的。

故三分就可以解决。最难的是公式是如何列出来,这么高深的物理公式 笑死*-*

h*cos(a)+(w-x*cos(a))/sin(a);

算了,这个题挺难得,公式难列出来。


感想:


具体的看一下下面的代码吧。三分角度。


AC代码:


#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
double PI=acos(-1.0);
double x,y,h,w;
double turn (double a)
{
    return h*cos(a)+(w-x*cos(a))/sin(a);
}
int main()
{
    //freopen("r.txt","r",stdin);
    double r,l,mid1,mid2;
    while(cin>>x>>y>>h>>w)
    {
        l=0;r=PI/2;
        while(r-l>0.0000001)
        {
            mid1=(r+2*l)/3;
            mid2=(l+r*2)/3;
            if(turn(mid1)>turn(mid2))
                r=mid2;
            else
                l=mid1;
        }
        if(turn(l)>y) cout<<"no"<<endl;
        else cout<<"yes"<<endl;
    }
    return 0;


}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值