POJ 3311 Hie with the Pie

Hie with the Pie

  • 原题

题目传送门!

Time Limit:2s

Memory Limit:65536K

Description

The Pizazz Pizzeria prides itself in delivering(快递) pizzas to its customers as fast as possible. Unfortunately, due to (由于)cutbacks(减少), they can afford to hire(雇用) only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria(当然是pizza店啦), even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned(委托) you to write a program to help him.

Input

Input will consist of(由...组成) multiple(多个) test cases. The first line will contain a single integer n indicating(表示) the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via(经过) other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e.(换言之), the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate(结束) input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

  • 题意

有一副n+1个点的完全图,要求从0出发,走完每个点之后再回到0点(每个点可重复走,每条边也可重复走),要求输出最短的路径的长度。

  • Solution

要求最短路,那就先跑一遍最短路嘛。看到1 ≤ n ≤ 10,用n^3跑一遍Floyd就行。

但是要注意,题目里说(因为没看见这句话,把dis[i][0]写成了dis[0][i],找了好久都不知道哪里错了)

the time to go directly from location i to j may not be the same as the time to go directly from location j to i.

跑完最短路之后就是这道题的关键——状压DP

dp[ i ] [ l ]表示当前到第 i 个点,去过的点集为 l(转换为二进制,这一位上为1的表示这个点在点集中)

转移方程:dp [ i ] [ l ] = min ( dp [ i ] [ l ] , dp [ j ] [ l - ( 1 << ( i - 1 ) ) ] + dis [ j ] [ i ] )

  • 上代码啦

#include <cstdio>
#include <algorithm>
#define N 11
#define INF 0xfffffff

using namespace std;

int n, i, j, ans, dis[N][N], dp[N][1 << N];
int main() {
	while(1) {
		scanf("%d", &n);
		if (n == 0) return 0;
		for (int i = 0; i <= n; ++i) {
			for (int j = 0; j <= n; ++j) {
				scanf("%d", &dis[i][j]);
			} 
		}
		for (int k = 0; k <= n; ++k) {//Floyd
			for (int i = 0; i <= n; ++i) {
				for (int j = 0; j <= n; ++j) {
					dis[i][j] = min(dis[i][j], dis[i][k] + dis[k][j]);
				}
			}
		}
		for (int l = 0; l < (1 << n); ++l) {//状压DP
			for (int i = 1; i <= n; ++i) {
				if (l == (1 << (i - 1))) {//当前点集中只有当前这个点,那就要走dis[0][i]了吖
					dp[i][l] = dis[0][i];
					continue;
				}
				dp[i][l] = INF;
				for (int j = 1; j <= n; ++j) {
					if ((i != j) && (l & (1 << (j - 1)))) {//i和j不同&点集中有j这个点
						dp[i][l] = min(dp[i][l], dp[j][l - (1 << (i - 1))] + dis[j][i]);
					}
				}
			}
		}
		ans = INF;
		for (int i = 1; i <= n; ++i) {
			ans = min(ans, dis[i][0] + dp[i][(1 << n) - 1]);
            /*注意点:1.dis[i][0]不要打错
                     2.位移的运算优先级比较低,一定不能忘记加"()"*/
		}
		printf("%d\n", ans);
	} 
	return 0;
}

That's it.祝大家coding愉快哦quq

  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值