Codeforces Round #290 (Div. 2)D

D. Fox And Jumping

  • 原题

Time Limit 2s

Memory Limit 256M

Fox Ciel is playing a game. In this game there is an infinite long tape with cells indexed by integers (positive, negative and zero). At the beginning she is standing at the cell 0.

There are also n cards, each card has 2 attributes: length li and cost ci. If she pays ci dollars then she can apply i-th card. After applying i-th card she becomes able to make jumps of length li, i. e. from cell x to cell (x - li) or cell (x + li).

She wants to be able to jump to any cell on the tape (possibly, visiting some intermediate cells). For achieving this goal, she wants to buy some cards, paying as little money as possible.

If this is possible, calculate the minimal cost.

Input

The first line contains an integer n (1 ≤ n ≤ 300), number of cards.

The second line contains n numbers li (1 ≤ li ≤ 109), the jump lengths of cards.

The third line contains n numbers ci (1 ≤ ci ≤ 105), the costs of cards.

Output

If it is impossible to buy some cards and become able to jump to any cell, output -1. Otherwise output the minimal cost of buying such set of cards.

SampleInput1

3
100 99 9900
1 1 1

SampleOutput1

2

SampleInput2

5
10 20 30 40 50
1 1 1 1 1

SampleOutput2

-1

SampleInput3

7
15015 10010 6006 4290 2730 2310 1
1 1 1 1 1 1 10

SampleOutput3

6

SampleInput4

8
4264 4921 6321 6984 2316 8432 6120 1026
4264 4921 6321 6984 2316 8432 6120 1026

SampleOutput4

7237

Note

In first sample test, buying one card is not enough: for example, if you buy a card with length 100, you can't jump to any cell whose index is not a multiple of 100. The best way is to buy first and second card, that will make you be able to jump to any cell.

In the second sample test, even if you buy all cards, you can't jump to any cell whose index is not a multiple of 10, so you should output -1.

  • 题意

给你n个数,每个数都有一个代价,每次能跳所购买的数的距离(向正负方向),问最少多少代价能跳到每一个整点上。

  • Solution

引理(emmm,容蒟蒻装个逼):要能跳到每个点上,所需的所有数值的gcd必须为1

证明:假设所需的所有数值的p=gcd(x_{1},x_{2},x_{3},...,x_{n})>1

x_{1}=p*y_{1},x_{2}=p*y_{2},x_{3}=p*y_{3},...,x_{n}=p*y_{n}(y_{i}为整数)

则在y_{i}在数轴y=x/p的整点上

于是x_{i}在数轴x=y*pp的倍数的点上,而p>1,则不能跳到所有的点上,矛盾

因此所需的所有数值的gcd必须为1

Q.E.D

RealSolution

这种可以选或不选的题型很容易让人想到01背包对吧,其实是类似的。

看到n=300,n个数中所有的组合的gcd\leq \sum_{i=1}^{n}\binom{n}{i}

可以用map过,每次向后转移,用map<gcd,cost>表示如果没有这个gcd就加入map,如果有的话就更新min(cost)

具体见代码(第一次打map...),不会的同学可以学习一下来自Boblim

  • Code(代码敲极短的quq)

#include <cstdio>
#include <algorithm>
#include <map>
#define N 305

using namespace std;

int a[N], c[N];
map <int, int> f;

int gcd(int x, int y) {
	if (y == 0) return x;
	return gcd(y, x % y);
}

int main() {
	int n;
	scanf("%d", &n);
	f[0] = 0;
	for (int i = 1; i <= n; ++i) {
		scanf("%d", &a[i]);
	}
	for (int i = 1; i <= n; ++i) {
		scanf("%d", &c[i]);
	}
	map <int, int> :: iterator it;
	for (int i = 1; i <= n; ++i) {
		for (it = f.begin(); it != f.end(); it++) {
			int p = it -> first;
			int g = gcd(p, a[i]);
			if (f.count(g)) f[g] = min(f[g], it -> second + c[i]);//更新min(cost)
			else f[g] = it -> second + c[i];//新增状态
		}
	}
	if (f.count(1)) printf("%d\n", f[1]);
	else printf("-1\n");
	return 0;
}

 

  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值