2632 Crashing Robots的解决方法

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into ea ch other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
2632 Crashing Robots(有点麻烦) - jolt2 - 正在成长的菜鸟 Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2
这也是一道模拟题,算法就是只要按照它的步骤来写,基本上没有什么难点。
有几个比较细节的地方要注意:
 
 
  1. 题目是先输入列行,再输入行数的。
  2. 行数是从下面开始数起的,另外行列数都是从1开始。
   我的解法是先把表格看一个直接的数组,下标从1开始(0的的省略)。此时题目给出的方向,我们需要进行转换,东西方向应该是不变的,但南北方向必须反向。因为我们是对一个二维数组直接存的。另外我规定N=1,W=2,S=3,E=4,在转向后方便知道是哪个方向左转(加)和右转(减)。由于我们开始的存储方式已经相反的,所以在NS方向的左转和右转 转向也是相反的。比如:N左转,则实际应该右转(好好理解)。如果机器人移动后撞墙了,则标记flag=1;如果撞到机器人了,则flag=2。
下面的是我的代码,没有去简化所以有点长,但是不难理解。
#include<stdio.h>
#include<string.h>
typedef struct
{
	int x,y;
}crd;
char ch[101][101];//必须大于101
int k,n,m,a,b,flag;
crd num[101],key;
int order_l(int n1, int n2)
{
	int j;
	j = n2 % 4;
	ch[num[n1].x][num[n1].y] += j;
	if(ch[num[n1].x][num[n1].y] > 4)
		ch[num[n1].x][num[n1].y] -= 4;
	return 1;
}
int order_r(int n1, int n2)
{
	int j = n2 % 4;
	ch[num[n1].x][num[n1].y] -= j;
	if(0 >= ch[num[n1].x][num[n1].y])
		ch[num[n1].x][num[n1].y] += 4;
	return 1;
}
int order_f(int n1,int n2)
{
	int j;
	for(j = 0; j <n2; j++)
	{
		switch(ch[num[n1].x][num[n1].y])
		{
			case 1:
				if(num[n1].x -1 <= 0)
				{flag = 1;break;}
				if(ch[num[n1].x - 1][num[n1].y] != 0 )
				{
					flag = 2;
					key = num[n1];
					key.x--;
				}
				else
				{				 
					ch[num[n1].x - 1][num[n1].y] = ch[num[n1].x][num[n1].y];
					ch[num[n1].x][num[n1].y] = 0;
					num[n1].x --;
				}
				break;
			case 2:
				if(num[n1].y - 1 <= 0)
				{flag = 1;break;}
				if(ch[num[n1].x][num[n1].y - 1] != 0 )
				{
					flag = 2;
					key = num[n1];
					key.y--;
				}
				else
				{				 
					ch[num[n1].x ][num[n1].y - 1] = ch[num[n1].x][num[n1].y];
					ch[num[n1].x][num[n1].y] = 0;
					num[n1].y--;
				}
				break;
			case 3:
				if(num[n1].x + 1 > b)
				{flag = 1;break;}
				if(ch[num[n1].x+1][num[n1].y] != 0 )
				{
					flag = 2;
					key = num[n1];
					key.x++;
				}
				else
				{				 
					ch[num[n1].x +1][num[n1].y] = ch[num[n1].x][num[n1].y];
					ch[num[n1].x][num[n1].y] = 0;
					num[n1].x++;
				}
				break;
			case 4:
				if(num[n1].y + 1 > a)
				{flag = 1;break;}
				if(ch[num[n1].x][num[n1].y + 1] != 0 )
				{				
					flag = 2;
					key = num[n1];
					key.y++;
				}
				else
				{				 
					ch[num[n1].x ][num[n1].y + 1] = ch[num[n1].x][num[n1].y];
					ch[num[n1].x][num[n1].y] = 0;
					num[n1].y++;
				}
				break;
		}
		if(flag>0)
			return flag;
	}
	return 0;
}
int main()
{
	int row,col,i,tmp;
	char dr,order;
	int n1,n2;
	memset(ch,0,sizeof(ch));
	scanf("%d",&k);
	while(k--)
	{	
		flag = 0;
		tmp = 0;
		scanf("%d%d",&a,&b);
		scanf("%d%d",&n,&m);
		for(i = 0;i < n;i++)
		{
		
			scanf("%d %d %c",&row,&col,&dr);
			switch(dr)
			{
			case 'E':tmp = 4;break;
			case 'S':tmp = 1;break;
			case 'W':tmp = 2;break;
			case 'N':tmp = 3;break;
			}
			ch[col][row] = tmp;
			num[i+1].x = col;
			num[i+1].y = row;
		}
		for(i = 0; i < m; i++)
		{
			scanf("%d %c %d",&n1, &order, &n2);
			if(flag == 0)
				switch(order)
				{
				case 'L':order_r(n1, n2);break;
				case 'R':order_l(n1, n2);break;
				case 'F':order_f(n1, n2);tmp=n1;break;
				}
		}
		switch(flag)
		{
		case 0:printf("OK\n");break;	
		case 1:printf("Robot %d crashes into the wall\n",tmp);break;
		case 2:
			for(i = 1;i<100;i++)
				if(key.x == num[i].x&&key.y==num[i].y)
					break;
				printf("Robot %d crashes into robot %d\n",tmp,i);
				break;
		}
	memset(ch,0,sizeof(ch));
	memset(num,0,sizeof(num));

	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值